Support Requests: Browse | Submit New | Admin

[#29755] Unable to make the initial push to my git repo

Date:
2013-06-10 15:41
Priority:
3
Submitted By:
Larry Dennison (lrdennison)
Assigned To:
Nobody (None)
Category:
None
State:
Open
Summary:
Unable to make the initial push to my git repo

Detailed description
Hi all, I hate to bother support but I've exhausted all web materials.

I've just been approved for a new project 'riceprotodoc'.  Most things seem to have been setup properly but I cannot
make the initial git push.  I've followed the directions in the FAQ (and elsewhere).  I get:

    Permission denied (publickey,gssapi-keyex,gssapi-with-mic).
    fatal: Could not read from remote repository.

    Please make sure you have the correct access rights
    and the repository exists.


I've verified that I can indeed sftp to the site (no password required) so I think my ssh keys are properly setup. 
I am to modify the project web pages just fine.

My remembrance of gitosis admin is that someone needs to create the initial repo on the upstream side (where I would
push to).  Makes sense, as you don't want people randomly creating new repos.

As a check, I tried to use the webgit browser (per your link) on my project.  Nothing is there.

I've also tried doing the read-only clone of the repo, it also isn't there.

I suspect that my repository wasn't created on the host.  What should I do?

Add A Comment: Notepad

Please login


Followup

No Followups Have Been Posted

Attached Files:

Name Description Download
No Files Currently Attached

Changes:

No Changes Have Been Made to This Item