Bugs: Browse | Submit New | Admin

[#27659] qt4-qtruby-2.0.3 not compile with Qt-4.6

Date:
2010-01-04 08:08
Priority:
3
Submitted By:
rtfm rtfm (rtfm)
Assigned To:
Nobody (None)
Category:
None
State:
Open
Summary:
qt4-qtruby-2.0.3 not compile with Qt-4.6

Detailed description
Scanning dependencies of target smokeqt
[  3%] Building CXX object smoke/qt/CMakeFiles/smokeqt.dir/smokedata.o
/pub/temp/qt4-qtruby-2.0.3/smoke/qt/smokedata.cpp:6109: ошибка: expected ‘}’ before ‘com’
/pub/temp/qt4-qtruby-2.0.3/smoke/qt/smokedata.cpp:6109: ошибка: expected ‘}’ before ‘com’
/pub/temp/qt4-qtruby-2.0.3/smoke/qt/smokedata.cpp:6109: ошибка: expected ‘,’ or ‘;’ before ‘com’
/pub/temp/qt4-qtruby-2.0.3/smoke/qt/smokedata.cpp:6109: ошибка: expected declaration before ‘}’ token
make[2]: *** [smoke/qt/CMakeFiles/smokeqt.dir/smokedata.o] Ошибка 1
make[1]: *** [smoke/qt/CMakeFiles/smokeqt.dir/all] Ошибка 2
make: *** [all] Ошибка 2

Gentoo-i686
gcc-4.4.1
cmake-2.8 or 2.6.4-r3
Qt-4.6.0-r1

Add A Comment: Notepad

Please login


Followup

Message
Date: 2010-06-04 20:58
Sender: Xavier Tô

I also wasn't able to compile it. I get a different error (though
almost the same)

Scanning dependencies of target smokeqt
[  3%] Building CXX object smoke/qt/CMakeFiles/smokeqt.dir/smokedata.o
/home/xto/temp/qt4-qtruby-2.0.3/smoke/qt/smokedata.cpp:6186:
error: expected ‘}’ before ‘com’
/home/xto/temp/qt4-qtruby-2.0.3/smoke/qt/smokedata.cpp:6186:
error: expected ‘}’ before ‘com’
/home/xto/temp/qt4-qtruby-2.0.3/smoke/qt/smokedata.cpp:6186:
error: expected ‘,’ or ‘;’ before ‘com’
/home/xto/temp/qt4-qtruby-2.0.3/smoke/qt/smokedata.cpp:6186:
error: expected declaration before ‘}’ token
make[2]: *** [smoke/qt/CMakeFiles/smokeqt.dir/smokedata.o] Error
1
make[1]: *** [smoke/qt/CMakeFiles/smokeqt.dir/all] Error 2
make: *** [all] Error 2


I'm on Kubuntu 10.04 with
gcc-4.4.3
cmake-2.8.1
Qt-4.6.2 
all from the Kubuntu repos....


Attached Files:

Name Description Download
No Files Currently Attached

Changes:

No Changes Have Been Made to This Item