Bugs: Browse | Submit New | Admin

[#27360] Using libxml-ruby with "uninitialized constant XML::Parser" failure

Date:
2009-10-27 13:48
Priority:
3
Submitted By:
Micha S. (jonino)
Assigned To:
Nobody (None)
Category:
None
State:
Open
Summary:
Using libxml-ruby with "uninitialized constant XML::Parser" failure

Detailed description
Hello,

If I use current libxml-ruby with aws_s3 I get the error: uninitialized constant XML::Parser
(gems/aws-s3-0.6.2/lib/aws/s3.rb:54 - XML::Parser::VERSION > '0.3.8.2'). AWS_S3 uses require_library_or_gem 'xml/libxml'
- but require 'xml/libxml' or require_library_or_gem 'xml/libxml' are deprecated. As a workaround I changed
XML::Parser::VERSION to LibXML::XML::Parser::VERSION.

Can soneone give me an better workaround without changing the gem or can you create a gem with correct Loading of libxml-ruby
requirement?

Micha

Add A Comment: Notepad

Please login


Followup

No Followups Have Been Posted

Attached Files:

Name Description Download
No Files Currently Attached

Changes:

No Changes Have Been Made to This Item