Patches: Browse | Submit New | Admin

[#22512] Inclusion de l'API de Google en version stable/normale/unstable

Date:
2008-10-22 14:05
Priority:
3
Submitted By:
Jérémy Lecour (eboss)
Assigned To:
Guilhem Vellut (gvellut)
Category:
None
State:
Open
Summary:
Inclusion de l'API de Google en version stable/normale/unstable

Detailed description
dans le fichier ym4r_gm/lib/gm_plugin/map.rb@34 il y a l'URL d'appel de l'API de Google. Le paramètre de version utilisé
est "2.x" ce qui correspond à la version la plus récente mais aussi la plus instable de l'API.

Comme précisé dans a doc [1] de Google pour son API, il y a 3 possibilités :

* 2.X : la version la plus récente ; ça peut changer plusieurs fois par jour mais le risque d'instabilité est assez
grand (je viens d'en faire violemment les frais ces derniers jours)
* 2 : la version normale ; tous les ajouts dans 2.x qui n'ont pas posé de soucis à l'echelle de quelques semaines
sont ajoutés en 2
* 2.s : la version stable ; idem que la 2, mais avec un tampon de plusieurs mois pour l'inclusion des nouveautés


Je pense que le plus sage serait d'inclure la version 2 ou bien de proposer le choix avec une valeur par défaut à 2.

Je tacherai de proposer un partch si j'en trouve le temps.

A suivre

[1] http://code.google.com/apis/maps/documentation/index.html#API_Updates

Add A Comment: Notepad

Please login


Followup

Message
Date: 2009-04-01 17:34
Sender: Matt Brennan

+1

http://groups.google.com/group/Google-Maps-API/browse_thread/thre
ad/90ae60390464a416

Attached Files:

Name Description Download
No Files Currently Attached

Changes:

No Changes Have Been Made to This Item