[wxruby-users] wxruby Installation woes on Ubuntu 9.10

Chauk-Mean Proum chauk.mean at gmail.com
Tue Nov 17 13:41:53 EST 2009


Hi Philip,

2009/11/15 Philip Stephens <plusgforce at gmail.com>:
> I have been having problems installing wxRuby and having it work on
> Ubuntu 9.10. To reproduce the problem I followed the following steps:
>
> 6 sudo apt-get install ruby
> 7 sudo apt-get install rubygems
> 8 sudo apt-get install libwxgtk2.8-0
> 9 sudo apt-gets install libwxgtk2.8-dev
> 10 sudo gem install wxruby

> /var/lib/gems/1.8/gems/wxruby-2.0.1-x86-linux/lib/wxruby2.so:
> /var/lib/gems/1.8/gems/wxruby-2.0.1-x86-linux/lib/wxruby2.so: symbol
> _ZN13wxAuiNotebook14ShowWindowMenuEv, version WXU_2.8.5 not defined in file
> libwx_gtk2u_aui-2.8.so.0 with link time reference -

The wxruby Linux gem has been built with/for Ubuntu 9.04.
A different C++ compiler version is shipped with Ubuntu 9.10 (g++ 4.4.1).
So the gem is not compatible with Ubuntu 9.10.

We may provide a Ubuntu-9.10 binary gem in the future but in the
meantime you have to build wxRuby yourself.

> I've tried to compile wxRuby from scratch but no luck.  What do I need to
> do?

I've added detailed steps to do that in the Wiki :
http://wxruby.rubyforge.org/wiki/wiki.pl?BuildingOnTopOfLinuxDistroPackages

Cheers.
Chauk-Mean.


More information about the wxruby-users mailing list