[Wtr-general] Problems accessing modal_dialog from ruby v. 1.8.5

Lauren forum-watir-users at openqa.org
Wed Feb 28 18:44:33 EST 2007

My ruby version is: 1.8.5
My watir version is:

I am having problems accessing a modal_dialog window that pops up in my web app. I've never accessed one before so I could be doing it all wrong, but  I have researched the forum archives extensively, tried several possible solutions and none of them have worked so far. 

I did read somewhere that modal_dialog only works with ruby 1.8.2??? Is this correct? Does this mean that since I am running ruby 1.8.5, I can expect modal_dialog to not work? Also, I've read that I need to "attach" to the modal dialog box. Is that something different than using the modal_dialog command?

Please help as I have been stuck on this one place in my script all day now!!

I've tried:
ie.modal_dialog.button(:index, 1).flash
ie.modal_dialog.button(:index, 2).click
ie.modal_dialog.frame(:index, 1).click
ie.modal_dialog.div(:index, 1).click
ie.modal_dialog.table(:index, 1).click

I have no idea what the dialog box is made of as I can't view it's objects.

Thanks again,
Posted via Jive Forums

More information about the Wtr-general mailing list