[Wtr-development] [JIRA] Updated: (WTR-282) Watir doesn't work on Cygwin [patch]

Zeljko (JIRA) watirjira at gmail.com
Wed Sep 1 03:16:30 EDT 2010

     [ http://jira.openqa.org/browse/WTR-282?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Zeljko updated WTR-282:

    Component/s:     (was: Modal Web Dialog)

> Watir doesn't work on Cygwin [patch]
> ------------------------------------
>                 Key: WTR-282
>                 URL: http://jira.openqa.org/browse/WTR-282
>             Project: Watir
>          Issue Type: Bug
>          Components: Modal Web Dialog
>    Affects Versions: 1.6.2
>         Environment: WinXP / Cygwin
>            Reporter: andyl
>            Priority: Blocker
>             Fix For: Soon
> On Cygwin, I ran into two separate problems that prevented Watir 1.6.2 from working.
> First, the 'win32ole.so' file that ships with Watir appears to be incompatible with the version that is installed with my copy of Cygwin-
> ruby. (see http://pastie.org/374756)
> An error message 'bad file permissions' was generated when trying to run  'x = Watir::IE.new' from within IRB.
> My workaround was to copy the 'ruby' version of win32ole.so into the 'watir' directories.  (see http://pastie.org/374865)
> Once this was done, another error occured - relating to modal dialogs.  (see http://pastie.org/374865)
> This was fixed by commenting out 2 lines in the Watir source code:
>     File - modal_dialog.rb    Line - 65 GetUnknown.call ...
>     File - win32.rb           Line - 6  GetUnknown = Win32API.new(...
> Once these lines were commented out, watir worked.
> Ideas for fixes:
> - Fix the modal dialog issue with conditional execution:
>   GetUnknown.call (...) unless  RUBY_PLATFORM == 'i386-cygwin'
>   GetUnknown=Win32APUI.new(...   unless RUBY_PLATFORM =='i386-cygwin'
> - Fix the win32ole issue by not bundling this file in the gem (Brett thinks maybe it is not needed??)
> - Cygwin support: run regression tests on cygwin!! 

This message is automatically generated by JIRA.
If you think it was sent incorrectly contact one of the administrators: http://jira.openqa.org/secure/Administrators.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira


More information about the Wtr-development mailing list