[Wtr-development] [JIRA] Reopened: (WTR-320) click_no_wait does not work on ruby186-27_rc2

Bret Pettichord (JIRA) watirjira at gmail.com
Tue Oct 19 21:48:20 EDT 2010


     [ http://jira.openqa.org/browse/WTR-320?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Bret Pettichord reopened WTR-320:
---------------------------------


Reopening so we can mark what version the fix is in.

> click_no_wait does not work on ruby186-27_rc2
> ---------------------------------------------
>
>                 Key: WTR-320
>                 URL: http://jira.openqa.org/browse/WTR-320
>             Project: Watir
>          Issue Type: Bug
>          Components: Inputs
>    Affects Versions: 1.6.2
>         Environment: Vista SP1 IE8, normal administrator account with default security settings (UAC enabled, IE protected mode enabled)
>            Reporter: Bill Agee
>            Priority: Major
>             Fix For: Next
>
>         Attachments: patch.txt
>
>
> Several people (including myself) have had problems using click_no_wait on Vista.
> The symptom is that the element being clicked will flash yellow, but nothing happens beyond that.  The click does not seem to be received.
> A patch that solves this problem was posted to the watir dev list, by Derek Berner:
> http://rubyforge.org/pipermail/wtr-development/2009-January/000400.html
> Looks like the patch was for Windows Server 2008, but it worked for me on Vista SP1 with IE8.
> But I tried the same patch on XP SP3, with IE8, and click_no_wait no longer worked.  A little work may be required to make sure the patch works on both Vista SP1 and XP.  Hopefully Server 2008 and Vista RTM will also both work if Vista SP1 has no problems.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.openqa.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        


More information about the Wtr-development mailing list