[Wtr-development] [JIRA] Commented: (WTR-459) click_no_wait does not work with frames

Jarmo Pertman (JIRA) watirjira at gmail.com
Thu Oct 14 11:48:20 EDT 2010

    [ http://jira.openqa.org/browse/WTR-459?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=19933#action_19933 ] 

Jarmo Pertman commented on WTR-459:

Ok, i tried the full cycle and got it working like this:
1) open watir-1.6.6\unittests\html\frame_buttons.html in IE
2) modify frame.rb attach_command as written above
3) add require "watir/frame" as above
4) run this script:
require "watir"
b = Watir::Browser.attach :url, //
$DEBUG = true
b.frame("buttonFrame").button(:id => "b2").click_no_wait

output should be something like that:

S:\>ruby blah.rb
Exception `WIN32OLERuntimeError' at C:/ruby_186p398/lib/ruby/gems/1.8/gems/watir
-1.6.6/lib/watir/element.rb:207 -
    OLE error code:0 in <Unknown>
      <No Description>
    HRESULT error code:0x80070057
      The parameter is incorrect.
#click_no_wait command:
ruby -e "require 'rubygems';require 'C:/ruby_186p398/lib/ruby/gems/1.8/gems/wati
r-1.6.6/lib/watir/core';Watir::Button.new(Watir::IE.attach(:hwnd, 2425434).frame
(:name, 'buttonFrame'), :unique_number, 1).click!"

and in the browser the button is clicked. The WIN32OLERuntimeError is normal.

And all of this worked for me fine. You are doing something wrong or have some wrong setup there since eval_in_spawned_process doesn't exist anywhere in 1.6.6. Try to `gem uninstall watir -v 1.6.6` and `gem install watir` to be sure you're at clean slate :)

If you get some errors, then please paste full stacktrace. Thanks.

> click_no_wait does not work with frames
> ---------------------------------------
>                 Key: WTR-459
>                 URL: http://jira.openqa.org/browse/WTR-459
>             Project: Watir
>          Issue Type: Bug
>          Components: Wait
>    Affects Versions: 1.6.6
>         Environment: ruby 1.8.6 (2007-09-24 patchlevel 111), Watir 1.6.6
>            Reporter: problem_child
>            Assignee: Jarmo Pertman
>            Priority: Blocker
> click_no_wait is not working in ruby 1.8.6 (2007-09-24 patchlevel 111), Watir 1.6.6
> $frame.button(:name, "button1").click_no_wait
> =>nil
> If I use $frame.button(:name, "button1").click it works so it is finding the object.
> But using click_no_wait results in nill using IRB.
> An error is not reported otherwise.

This message is automatically generated by JIRA.
If you think it was sent incorrectly contact one of the administrators: http://jira.openqa.org/secure/Administrators.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira


More information about the Wtr-development mailing list