[Win32utils-devel] [ win32utils-Feature Requests-28841 ] Why not create fat binary gems for all win32 utils gems?

noreply at rubyforge.org noreply at rubyforge.org
Fri Jan 10 16:15:50 UTC 2014


Feature Requests item #28841, was opened at 2011-01-09 07:58
You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=414&aid=28841&group_id=85

Category: None
Group: None
>Status: Closed
>Resolution: Out of Date
Priority: 3
Submitted By: Jarmo Pertman (juuser)
Assigned to: Nobody (None)
Summary: Why not create fat binary gems for all win32 utils gems?

Initial Comment:
Currently if you install any of the win32-* gems then it will work only with Ruby 1.8.x due to the precompiled binary for that version. Why not create a pre-compiled versions for 1.9.x too and package them as a so called fat-binary gems?

This would make all those gems (probably) work with 1.9 Ruby too. Currently many gems cannot be used in 1.9 because they're using win32-* gems as a dependency.

----------------------------------------------------------------------

>Comment By: Daniel Berger (djberg96)
Date: 2014-01-10 09:15

Message:
This is mostly no longer relevant, as we've converted (or are in the process of converting) all of the gems to FFI.

For the win32-api gem I am currently bundling multiple versions of precompiled binaries, so it should work no matter which version of Ruby you're using (up through 2.0 anyway).

----------------------------------------------------------------------

Comment By: Jarmo Pertman (juuser)
Date: 2011-01-10 09:14

Message:
That would be also great, although would need additional 
manual work to be done each time a new version of gem is going 
to be released.

That's where rake compiler could help i suppose.

----------------------------------------------------------------------

Comment By: Daniel Berger (djberg96)
Date: 2011-01-10 08:11

Message:
I guess I'll just install the 1.9.x installer for Windows, and start shipping two binaries for win32-api. The api.rb file will just require the appropriate binary based on your Ruby version.

----------------------------------------------------------------------

Comment By: Jarmo Pertman (juuser)
Date: 2011-01-09 09:44

Message:
Luis, that would be great if you'd be able to help out to make 
win32 gems work under 1.9 too. As stated in my original 
request then they're playing quite big part of many other gems 
and are affecting Windows Ruby users experience negatively on 
Ruby 1.9.

----------------------------------------------------------------------

Comment By: Luis Lavena (luislavena)
Date: 2011-01-09 09:35

Message:
Hello,

Me chiming in.

To be able to create the fat-binary gems you need Linux, as currently rake-compiler, the only project able to generate these automatically, only support that functionality on non-Windows platforms.

It is in the Roadmap, but no ETA.

So, either the fat-binary gems need to be created manually or on a non-Windows platform that support rake-compiler.

Daniel, feel free to contact me at RubyInstaller list to discuss this.


----------------------------------------------------------------------

You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=414&aid=28841&group_id=85


More information about the win32utils-devel mailing list