[Win32utils-devel] JRuby shell issue

Daniel Berger djberg96 at gmail.com
Thu Oct 24 12:55:51 UTC 2013


After inspecting my ENV['PATH'] I noticed that one of the entries contained
an empty string! This was caused by a double semicolon in my PATH string.
Which I guess is interpreted as "current directory". I'm not entirely clear
how calling jruby worked at all, though.

Either I did that by mistake at some point, or one of the apps I installed
messed it up during installation (either Oracle or Perl, based on where it
was). Anyway, once I fixed that, it worked fine.



On Wed, Oct 23, 2013 at 7:09 PM, Heesob Park <phasis at gmail.com> wrote:

> Hi,
> 2013/10/24 Daniel Berger <djberg96 at gmail.com>:
> > Hi,
> >
> > JRuby 1.7.6 on Windows 7, installed under C:\jruby.
> >
> > For some reason I'm having trouble running this with a standard command
> > shell. If I run "jruby -v" nothing happens. However, if I run it from a
> > mingw shell, it works fine. It also works fine if I specify the path
> > explicitly, c:\jruby\bin\jruby -v.
> >
> > As far as I can tell my PATH is set fine. jirb seemed to work fine, too.
> >
> > Any ideas?
> >
> I cannot reproduce your issue on my Windows 7.
> I guess that jruby.exe(jruby.bat,jruby.cmd or jruby.rb) might be exist
> on the other path which is in %PATH% prior to c:\jruby\bin.
> Regards,
> Park Heesob
> _______________________________________________
> win32utils-devel mailing list
> win32utils-devel at rubyforge.org
> http://rubyforge.org/mailman/listinfo/win32utils-devel
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/win32utils-devel/attachments/20131024/1539a9d2/attachment.html>

More information about the win32utils-devel mailing list