[Win32utils-devel] File.realpath

Daniel Berger djberg96 at gmail.com
Wed Nov 20 14:40:25 UTC 2013


On Wed, Nov 20, 2013 at 7:31 AM, Daniel Berger <djberg96 at gmail.com> wrote:

> Hi,
>
>
>>  > You shouldn't be getting the "rake aborted!" though. If you fix that
>> test
>> > and run them again do you still see that?
>> >
>> It seems that "rake aborted!" means there is at least one failure.
>>
>> I'm not sure it is a bug of feature, a simple test with
>> "assert_equal(1,2)" produce "rake aborted!"
>
>
> I'm seeing it every other run, even without test failures:
>
> C:\Users\djberge\Repositories\win32-file>rake test:link
> c:/ruby264/bin/ruby.exe -w -I"lib"
> -I"c:/ruby264/lib/ruby/gems/2.0.0/gems/rake-10.1.0/lib"
> "c:/ruby264/lib/ruby/gems/2.0.0/gems/rake-10.1.0/lib/rake/rake_test_loader.rb"
> "test/test_win32_file_link.rb"
> c:/ruby264/lib/ruby/gems/2.0.0/gems/win32-file-stat-1.4.0/lib/win32/file/stat.rb:60:
> warning: method redefined; discarding old initialize
> Loaded suite
> c:/ruby264/lib/ruby/gems/2.0.0/gems/rake-10.1.0/lib/rake/rake_test_loader
> Started
> .................
>
> Finished in 0.128007 seconds.
>
> 17 tests, 26 assertions, 0 failures, 0 errors, 0 pendings, 0 omissions, 0
> notifications 100% passed
>
> 132.81 tests/s, 203.11 assertions/s
> rake aborted!
> Command failed with status (116): [ruby -w -I"lib"
> -I"c:/ruby264/lib/ruby/gems/2.0.0/gems/rake-10.1.0/lib"
> "c:/ruby264/lib/ruby/gems/2.0.0/gems/rake-10.1.0/lib/rake/rake_test_loader.rb"
> "test/test_win32_file_link.rb" ]
>
> Tasks: TOP => test:link
> (See full trace by running task with --trace)
>
> BTW, I'm seeing this with the latest in FFI, which fixes one test, and
makes the File.readlink method raise an error if the argument is not a
symlink.

Regards,

Dan
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/win32utils-devel/attachments/20131120/4850e102/attachment.html>


More information about the win32utils-devel mailing list