[Win32utils-devel] win32-service patch

Daniel Berger djberg96 at gmail.com
Mon Jun 17 02:55:59 UTC 2013


It's looking good! I did reorganize the code a bit - moving functions,
structs and constants to their individual files.

It worked fine with MRI. The only quirk I noticed was that Service.start
seemed to block on the command line for me, but it did work.

For JRuby, I was able to install the demo service fine, but when I tried to
start it I got this:

Errno::ENOENT: No such file or directory - StartService: The system cannot
find the file specified.
  raise_windows_error at
c:/Users/djberge/Repositories/win32-service/lib/win32/windows/helper.rb:36
start at
c:/Users/djberge/Repositories/win32-service/lib/win32/service.rb:725 (root)
at examples\demo_daemon_ctl.rb:68

Maybe it's not liking the args pointer approach used there, but I'm not
sure.

I'll futz with it some more tomorrow.

Cheers!

Dan


On Sat, Jun 15, 2013 at 10:19 AM, Heesob Park <phasis at gmail.com> wrote:

> Hi,
>
> 2013/6/12 Heesob Park <phasis at gmail.com>:
> > Hi,
> >
> > 2013/6/12 Daniel Berger <djberg96 at gmail.com>:
> >> Do you have the code for FFI? I've got a partial conversion done, but
> I'll
> >> stop if you have your code available. Please commit it to the 'ffi'
> branch
> >> if you have it.
> >>
> > I do not want to commit the not working code.
> > I tried the ffi code also on Ruby 2.0.0, but it did not work too.
> >
> > Nevertheless, here is the ffi converted code for your reference.
> > https://gist.github.com/phasis68/5762071
> >
> Now, I finally got the working ffi daemon code.
> The gist  https://gist.github.com/phasis68/5762071 is the latest version.
>
> Regards,
> Park Heesob
> _______________________________________________
> win32utils-devel mailing list
> win32utils-devel at rubyforge.org
> http://rubyforge.org/mailman/listinfo/win32utils-devel
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/win32utils-devel/attachments/20130616/68362132/attachment.html>


More information about the win32utils-devel mailing list