[Win32utils-devel] JRuby devkit "gem install win32-api" fails. what to do?

Daniel Berger djberg96 at gmail.com
Mon Mar 5 00:10:35 UTC 2012


On Sun, Mar 4, 2012 at 4:17 PM,  <craig at coot.net> wrote:
>
> I'm working on using JRuby in a windows shop.  Install of gem win32-api
> failed.
>
> $ gem install win32-api --version '~> 1.4.8'
>
> I put a log at
> https://gist.github.com/1966688
>
> I think the RubyInstaller devkit is properly attached to the JRuby 1.6.7.
>
> Any ideas on what to do?

I'm afraid JRuby and win32-api are incompatible at the moment. I'm
actually busy converting the windows-pr library to use ffi, which will
obviate the need for win32-api altogether. Heesob has done some
fantastic work to make ffi work with MSVC++, so that's what is driving
the overhaul.

Once the next ffi version is released that includes MSVC++ support and
I've finished windows-pr, I'll start converting the various win32 libs
to use ffi instead.

Do you have a particular win32 lib you want converted first?

Regards,

Dan


More information about the win32utils-devel mailing list