[Win32utils-devel] Win32-api 1.4.6 release and mswin32 binary?

Luis Lavena luislavena at gmail.com
Thu Feb 11 14:57:38 EST 2010


On Thu, Feb 11, 2010 at 7:40 PM, Charley Baker <charley.baker at gmail.com> wrote:
> Hey all,
>
>
> Before this starts to bite us too much. It looks like there's a new release
> of win32-api gem - 1.4.6, which only has a mingw precompiled binary, as
> opposed the mswin binaries for the previous versions. Is there a mswin
> binary in the works, otherwise projects depending on this and people using
> the one click installer are going to, and are getting errors trying to
> compile.
>

If the project used rake-compiler, release of binary versions for both
gem platforms will only take change:

ext.platform = "i386-mingw32"

to

ext.platform = ["i386-mingw32", "i386-mswin32-60"]

Also, if the gem was built using rake-compiler, installation process
should work smoothly with either VC6 or MinGW, as long you have all
the headers in place and extconf.rb do not do weird things.
-- 
Luis Lavena
AREA 17
-
Perfection in design is achieved not when there is nothing more to add,
but rather when there is nothing more to take away.
Antoine de Saint-Exupéry


More information about the win32utils-devel mailing list