[Win32utils-devel] [ win32utils-Bugs-28003 ] gem only includes 1.8 version

noreply at rubyforge.org noreply at rubyforge.org
Sat Apr 24 17:03:51 EDT 2010


Bugs item #28003, was opened at 2010-03-24 16:06
You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=411&aid=28003&group_id=85

Category: win32-api
Group: None
Status: Open
Resolution: None
Priority: 3
Submitted By: Roger Pack (rogerdpack)
Assigned to: Nobody (None)
Summary: gem only includes 1.8 version

Initial Comment:
Currently in mingw:

C:\dev\ruby\downloads>gem install win32-api
Successfully installed win32-api-1.4.6-x86-mingw32
1 gem installed

C:\dev\ruby\downloads>irb
irb(main):001:0> exit

C:\dev\ruby\downloads>ruby -v
ruby 1.9.1p376 (2009-12-07 revision 26041) [i386-mingw32]

C:\dev\ruby\downloads>irb
irb(main):001:0> require 'win32/api'
# a popup appears saying "cannot find libmsvcrt18.dll" or something
LoadError: 126: The specified module could not be found.   - C:/installs/ruby191p376/lib/ruby/gems/1.9.1/gems/win32-api-1.4.6-x86-mingw32/lib/win32/api.so
        from (irb):1:in `require'
        from (irb):1
        from C:/installs/ruby191p376/bin/irb:12:in `<main>'

Works find with 1.8.6 though.

Thanks.
-rp

----------------------------------------------------------------------

>Comment By: Roger Pack (rogerdpack)
Date: 2010-04-24 21:03

Message:
Currently I think gems forces you to package *both* 
binaries into one "fat binary" (which is what I do, using 
rake-compiler for cross compiling).
Thanks!
-rp

----------------------------------------------------------------------

Comment By: Daniel Berger (djberg96)
Date: 2010-04-24 13:14

Message:
I don't actually know how you're supposed to package binaries to multiple versions of Ruby. I'll have to ask.

Regards,

Dan

----------------------------------------------------------------------

You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=411&aid=28003&group_id=85


More information about the win32utils-devel mailing list