[Win32utils-devel] [ win32utils-Bugs-23761 ] crash when require 'win32/file' is followed by another require statement

noreply at rubyforge.org noreply at rubyforge.org
Sat Jan 31 17:22:42 EST 2009


Bugs item #23761, was opened at 2009-01-31 17:16
You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=411&aid=23761&group_id=85

Category: win32-file
Group: None
Status: Open
Resolution: None
Priority: 3
Submitted By: Montgomery Kosma (mkosma)
Assigned to: Nobody (None)
Summary: crash when require 'win32/file' is followed by another require statement

Initial Comment:
gem --version win32-file => 1.3.1

1. Seems I cannot require anything after 'win32/file' without generating an error.
The following 3-line foo.rb dies as shown below:

====================================
require 'win32/file'
require 'trollop'  # same behavior with various different requires
puts 'hello world'
====================================

C:\docs\Prog\PSTTools>foo.rb
c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in `gem_original_require': no such file to load -- trollop (LoadError)
        from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in `require'
        from C:/docs/Prog/PSTTools/foo.rb:2


2. No error occurs if I reverse the order of the two requires.


----------------------------------------------------------------------

>Comment By: Montgomery Kosma (mkosma)
Date: 2009-01-31 17:22

Message:
sorry, provided gem version not win32-file version.

win32-file (0.6.0)
win32-file-stat (1.3.2)


----------------------------------------------------------------------

You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=411&aid=23761&group_id=85


More information about the win32utils-devel mailing list