[Win32utils-devel] [ win32utils-Bugs-23762 ] incompatibility with rubyscript2exe

noreply at rubyforge.org noreply at rubyforge.org
Sat Jan 31 17:21:25 EST 2009


Bugs item #23762, was opened at 2009-01-31 17:21
You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=411&aid=23762&group_id=85

Category: win32-file
Group: None
Status: Open
Resolution: None
Priority: 3
Submitted By: Montgomery Kosma (mkosma)
Assigned to: Nobody (None)
Summary: incompatibility with rubyscript2exe

Initial Comment:
Attempting to "compile" script with win32/file generates an error.

win32-file (0.6.0)
win32-file-stat (1.3.2)
rubyscript2exe (0.5.3)

#foo.rb
require 'win32/file'
puts 'hello world'

Error:

C:\docs\Prog\PSTTools>rubyscript2exe foo.rb
Tracing foo ...
hello world
Gathering files...
c:/temp/tar2rubyscript.d.1796.1/rubyscript2exe/require2lib.rb:56:in `mkdir': No
such file or directory - c:/temp/oldandnewlocation.1796/lib/rubyscript2exe.gems
(Errno::ENOENT)
        from c:/temp/tar2rubyscript.d.1796.1/rubyscript2exe/require2lib.rb:56:in `gatherlibs'
        from c:/temp/tar2rubyscript.d.1796.1/rubyscript2exe/require2lib.rb:30
        from foo.rb:3
Couldn't execute this command (rc=256):
c:\ruby\bin\ruby -r 'enumerator.so' -r 'rubygems/rubygems_version.rb' -r 'rubygems/defaults.rb' -r 'thread.so' -r 'thread.rb' -r 'rbconfig.rb' -r 'rubygems/exceptions.rb' -r 'rubygems/requirement.rb' -r 'rubygems/version.rb' -r 'rubygems/dependency.rb' -r 'rubygems/gem_path_searcher.rb' -r 'rubygems/user_interaction.rb
' -r 'rubygems/platform.rb' -r 'rubygems/specification.rb' -r 'rubygems/source_index.rb' -r 'rubygems/builder.rb' -r 'stringio.so' -r 'yaml/error.rb' -r 'syck.so' -r 'yaml/ypath.rb' -r 'yaml/basenode.rb' -r 'yaml/syck.rb' -r 'yaml/tag.rb' -r 'yaml/stream.rb' -r 'yaml/constants.rb' -r 'rational.rb' -r 'date/format.rb' -r 'date.rb' -r 'yaml/rubytypes.rb' -r 'yaml/types.rb' -r 'yaml.rb' -r 'Win32API.so' -r 'rubygems/config_file.rb' -r 'rubygems/custom_require.rb' -r 'rubygems.rb' -r 'ubygems.rb' -r 'etc.so' -r 'fileutils.rb' -I 'c:/temp/tar2rubyscript.d.1796.1/rubyscript2exe' -I 'c:/temp/tar2rubyscript.d.1796.1' -I './lib' -I 'c:/docs/prog/ruby/lib' -I 'c:/ruby/lib/ruby/gems/1.8/gems/rubyscript2exe-0.5.3/bin' -I 'c:/ruby/lib/ruby/gems/1.8/gems/rubyscript2exe-0.5.3/lib' -I 'c:/ruby/lib/ruby/site_ruby/1.8' -I 'c:/ruby/lib/ruby/site_ruby/1.8/i386-msvcrt' -I 'c:/ruby/lib/ruby/site_ruby' -I 'c:/ruby/lib/ruby/vendor_ruby/1.8' -I 'c:/ruby/lib/ruby/vendor_ruby/1.8/i386-msvcrt' -I 'c:/ruby/lib/ruby/vendor_ruby' -I 'c:/ruby/lib/ruby/1.8'
 -I 'c:/ruby/lib/ruby/1.8/i386-mswin32' -I '.' -I 'C:/docs/Prog/PSTTools' -I 'c:/temp/tar2rubyscript.d.1796.1/rubyscript2exe' -I 'c:/temp/tar2rubyscript.d.1796.1/rubyscript2exe/lib' -I 'c:/temp/tar2rubyscript.d.1796.1/rubyscript2exe' -I 'c:/temp/tar2rubyscript.d.1796.1/rubyscript2exe/lib' -r 'c:/temp/tar2rubyscript.d.1796.1/rubyscript2exe/require2lib.rb' 'foo.rb'
Stopped.

----------------------------------------------------------------------

You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=411&aid=23762&group_id=85


More information about the win32utils-devel mailing list