[Win32utils-devel] [ win32utils-Bugs-26975 ] Two test failures on XP virtual machine

noreply at rubyforge.org noreply at rubyforge.org
Fri Aug 21 13:52:37 EDT 2009


Bugs item #26975, was opened at 2009-08-21 10:52
You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=411&aid=26975&group_id=85

Category: win32-sapi
Group: Code
Status: Open
Resolution: None
Priority: 3
Submitted By: Daniel Berger (djberg96)
Assigned to: Nobody (None)
Summary: Two test failures on XP virtual machine

Initial Comment:
Ruby 1.8.6-p383
VC++ 9
Windows XP Pro (VM via VMWare Fusion)

On my XP VM I get the following test failures:

C:\Documents and Settings\djberge\workspace\win32-sapi>rake test
(in C:/Documents and Settings/djberge/workspace/win32-sapi)
C:/Ruby/bin/ruby.exe -w -I"lib" "C:/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake/rake_test_loader.rb" "test/test_win32_sapi5.rb"
Loaded suite C:/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake/rake_test_loader
Started
...F.........F......
Finished in 0.375 seconds.

  1) Failure:
test_SpInProcRecoContext(TC_Win32_SAPI5) [./test/test_win32_sapi5.rb:38]:
Exception raised:
Class: <WIN32OLERuntimeError>
Message: <"failed to create WIN32OLE object from `{73AD6842-ACE0-45E8-A4DD-8795881A2C2A}'\n    HRESULT error code:0x8004503a\n      ">
---Backtrace---
./lib/win32/sapi5.rb:51:in `initialize'
./lib/win32/sapi5.rb:51:in `initialize'
./test/test_win32_sapi5.rb:38:in `new'
./test/test_win32_sapi5.rb:38:in `test_SpInProcRecoContext'
./test/test_win32_sapi5.rb:38:in `test_SpInProcRecoContext'
---------------

  2) Failure:
test_SpSharedRecoContext(TC_Win32_SAPI5) [./test/test_win32_sapi5.rb:78]:
Exception raised:
Class: <WIN32OLERuntimeError>
Message: <"failed to create WIN32OLE object from `{47206204-5ECA-11D2-960F-00C04F8EE628}'\n    HRESULT error code:0x8004503a\n      ">
---Backtrace---
./lib/win32/sapi5.rb:144:in `initialize'
./lib/win32/sapi5.rb:144:in `initialize'
./test/test_win32_sapi5.rb:78:in `new'
./test/test_win32_sapi5.rb:78:in `test_SpSharedRecoContext'
./test/test_win32_sapi5.rb:78:in `test_SpSharedRecoContext'
---------------

20 tests, 20 assertions, 2 failures, 0 errors
rake aborted!
Command failed with status (1): [C:/Ruby/bin/ruby.exe -w -I"lib" "C:/Ruby/l...]

(See full trace by running task with --trace)

Simply not supported? Or are they actually different values?

Regards,

Dan (me)

----------------------------------------------------------------------

You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=411&aid=26975&group_id=85


More information about the win32utils-devel mailing list