[Win32utils-devel] Comments for Daniel Berger blog post

Heesob Park phasis at gmail.com
Sat Aug 8 22:03:40 EDT 2009


2009/8/9 Luis Lavena <luislavena at gmail.com>:
> On Sat, Aug 8, 2009 at 9:06 PM, Heesob Park<phasis at gmail.com> wrote:
>> Hi,
>>
>> 2009/8/9 Luis Lavena <luislavena at gmail.com>:
>>> [LONG SNIP]
>>
>> Thanks for your a little long summary :)
>
> Apologizes, needed to get it out of my chest.
>
> I posted about VC8 back in January 2008:
>
> http://rubyforge.org/pipermail/rubyinstaller-devel/2008-January/000230.html
>
> Taking in consideration was doing what "Average Joe" will do, not
> being a VS expert or anything like that.
>
> Wonder how PGO compilation after running the test can improve those values.
>
>> I understand your situation and despair.
>>
>> Now I really want to know is that the mingw32 compiled dll is
>> compatible with mswin32 version of ruby. Is there any way to make a
>> dll build with mingw32 compiler to compatible both mingw32 and mswin32
>> version?
>>
>
> Yes, GCC links and target by default to MSVCRT.DLL, which makes
> mingw32 binaries compatible with mswin32 ones.
>
If mingw32 binaries are compatible with mswin32, I think ffi-0.4.0
binary might be compatible with mswin32_90 version of ruby.
What's the way to install ffi-0.4.0 mingw32 binary gem to mswin32_90
version of ruby?

> Everything will be great as long both target and use the same CRT.
>
I'm not sure what you mean by "as long both target and use the same CRT".


Regards,

Park Heesob


More information about the win32utils-devel mailing list