[Win32utils-devel] Please update your rubygems

Daniel Berger djberg96 at gmail.com
Fri Apr 17 01:08:12 EDT 2009

Hi folks,

I know, it's been a while since I posted. I've devoted most of my energy in
the last few months to the latest release of rubygems. I highly recommend
upgrading to 1.3.2 if you haven't done so already, as it fixes an issue
brought up by Montgomery Kosma where require'ing any file after require'ing
win32-file would cause a LoadError.

It also fixed an issue with rubygems creating extraneous quotation marks
when generating .bat files.

In other news, one of the next issues in rubygems we will need to tackle
(brought up by Luis Lavena) is how to tag gems for specific versions of
Ruby. Specifically, if you want to generate two separate binary gems with
the same name, but for different versions of ruby, there's no way to
distinguish the gems short of using a different version number. This is
largely an MS Windows issue, so I thought it worthwhile to bring up here.

and following. Suggestions welcome.



More information about the win32utils-devel mailing list