[Win32utils-devel] [Fwd: [win32utils-help][6822] Eventlog problem]

Daniel Berger djberg96 at gmail.com
Sat Jan 7 09:38:09 EST 2006


Park Heesob wrote:

>Hi,
>----- Original Message ----- 
>From: "Daniel Berger" <djberg96 at gmail.com>
>To: "Development and ideas for win32utils projects" 
><win32utils-devel at rubyforge.org>
>Sent: Thursday, January 05, 2006 11:53 PM
>Subject: [Win32utils-devel] [Fwd: [win32utils-help][6822] Eventlog problem]
>
>
>  
>
>>Dang, I thought we solved this.
>>
>>Any ideas?
>>
>>    
>>
>It seems another bug.
>I cannot reproduce same problem.
>Could you send me a crashed event log backup file?
>
>  
>
>>PS - I realized after reading this I forgot to bump the version number
>>for 0.3.3 - I've uploaded a new zip file with the correct version number.
>>
>>    
>>
>BTW, I found a bug in open_backup method.
>It often raised segmentation fault when reading backup event log file.
>The eventlog_open_backup function in eventlog.c should be modified like 
>this:
>
>  
>
Although you are correct that the first argument to open_backup should 
be mandatory, that's not the problem.  I went back and figured out that 
something broke between 0.2.4 and 0.2.5 (and I'm probably the one that 
broke it, sorry).  I've made both 0.2.4 and 0.2.5 public again, so you 
can download them from the project page and try to figure out what I 
screwed up.

Attached is the log file causing the problem.

Dan
-------------- next part --------------
A non-text attachment was scrubbed...
Name: System.bak
Type: application/octet-stream
Size: 269012 bytes
Desc: not available
Url : http://rubyforge.org/pipermail/win32utils-devel/attachments/20060107/4fd26667/System-0001.obj


More information about the win32utils-devel mailing list