[Win32utils-devel] Tweak to win32-eventlog

Wayne Vucenic waynev at gmail.com
Wed Dec 20 22:47:25 EST 2006


Hi Dan,

> I should have release 0.4.3 out today.

I tried the 0.4.3 gem on my XP system that was having the problem before:

C:\ruby\lib\ruby\gems\1.8\gems\win32-eventlog-0.4.3\test>ruby tc_eventlog.rb

Relax - this will take a few moments

Loaded suite tc_eventlog
Started
...................FF....F
Finished in 317.016 seconds.

  1) Failure:
test_seek_read(TC_EventLog) [tc_eventlog.rb:116]:
<11> expected but was
<0>.

  2) Failure:
test_seek_read_backwards(TC_EventLog) [tc_eventlog.rb:123]:
<10> expected but was
<0>.

  3) Failure:
test_version(TC_EventLog) [tc_eventlog.rb:29]:
<"0.4.2"> expected but was
<"0.4.3">.

26 tests, 5206 assertions, 3 failures, 0 errors

It looks like something didn't get updated for 0.4.3.  I notice that
the tc_eventlog.rb
file is identical between 0.4.2 and 0.4.3.

I then tried it on my Win2K system that used to work, and I get:

C:\ruby\lib\ruby\gems\1.8\gems\win32-eventlog-0.4.3\test>ruby tc_eventlog.rb

Relax - this will take a few moments

Loaded suite tc_eventlog
Started
...................FF....F
Finished in 0.609 seconds.

  1) Failure:
test_seek_read(TC_EventLog) [tc_eventlog.rb:116]:
<11> expected but was
<0>.

  2) Failure:
test_seek_read_backwards(TC_EventLog) [tc_eventlog.rb:123]:
<10> expected but was
<0>.

  3) Failure:
test_version(TC_EventLog) [tc_eventlog.rb:29]:
<"0.4.2"> expected but was
<"0.4.3">.

26 tests, 82 assertions, 3 failures, 0 errors

It's odd that I'm now seeing the two failures on this system, as I didn't
see them before.

Thanks,

Wayne


More information about the win32utils-devel mailing list