[Win32utils-devel] PATCH: win32-open3 and ruby 1.8.3 compatibility

Berger, Daniel Daniel.Berger at qwest.com
Wed Oct 26 12:35:36 EDT 2005

> -----Original Message-----
> From: win32utils-devel-bounces at rubyforge.org 
> [mailto:win32utils-devel-bounces at rubyforge.org] On Behalf Of 
> Nathaniel Talbott
> Sent: Wednesday, October 26, 2005 7:40 AM
> To: Development and ideas for win32utils projects
> Subject: [Win32utils-devel] PATCH: win32-open3 and ruby 1.8.3 
> compatibility
> I've attached the patch I had to make to get open3 to work 
> under 1.8.3. It doesn't take backwards compatibility in to 
> account, so that'll probably have to be addressed.

Thanks Nathaniel.  I'm curious why they felt compelled to add an
rb_pid_t data type.  I suppose we'll have to do some preprocessor checks
in the extconf.rb file now, or create our own macro to deal with it.



More information about the win32utils-devel mailing list