[Win32utils-devel] Re: test/unit error report for win32-service

Daniel Berger djberg96 at yahoo.com
Tue Mar 1 08:53:15 EST 2005


Hi,

--- Shashank Date <sdate at everestkc.net> wrote:

> Dan,
> 
> I am assuming that the version in  CVS is the most
> current one.
> Report follows.
> -- shanko
>
------------------------------------------------------
> C:\win32utils\win32-service\test>ruby tc_service.rb
>    This test will stop and start your Clipboard
> service, as well as
> pause and
>    resume your Schedule service.  This is harmless
> unless you are actually
>    using these services at the moment you run this
> test.  Is it OK to
>    proceed? (y/N)
> y
> This will take a few seconds.  Be patient...
> Loaded suite tc_service
> Started
> .....F.............tc_service.rb:134: warning:
> redefining constant
> Struct::Win32Service
> ..E.tc_service.rb:199: warning: redefining constant
> Struct::Win32ServiceStatus
> .F
> Finished in 7.481 seconds.

I fixed this warning in 0.4.5
 
>   1) Failure:
> test_create_delete(TC_Win32Service)
> [tc_service.rb:164]:
> Exception raised:
> Class: <Win32::ServiceError>
> Message: <"The specified service already exists.">
> ---Backtrace---
> tc_service.rb:165:in `create_service'
> tc_service.rb:165:in `test_create_delete'
> tc_service.rb:164:in `assert_nothing_raised'
> tc_service.rb:164:in `test_create_delete'

I suspect what happened here is that the test was
created in an earlier test run, but was never deleted.
 For this case, I would suggest manually deleting the
"foo" service, and running the test script again.

> ---------------
> 
>   2) Error:
> test_start_stop(TC_Win32Service):
> Win32::ServiceError: The dependency service or group
> failed to start.
>     tc_service.rb:140:in `start'
>     tc_service.rb:140:in `test_start_stop'

Yeah, I made a note about this one in the README file.
 It appears that the Network DDE service is turned now
off by default (as of SP2?), which is the dependency
in question that it's complaining about.  You can
either ignore it or turn on the Network DDE service
and try again.

> 
>   3) Failure:
> test_version(TC_Win32Service) [tc_service.rb:52]:
> Bad version.
> <"0.4.5"> expected but was
> <"0.4.4">.

Fixed in 0.4.5 - you must have gotten to it before the
final release. ;)

> C:\win32utils\win32-service\test>ruby tc_daemon.rb
> Loaded suite tc_daemon
> Started
> ...F
> Finished in 0.02 seconds.
> 
>   1) Failure:
> test_version(TC_Daemon) [tc_daemon.rb:24]:
> <"0.4.5"> expected but was
> <"0.4.4">.

Again, fixed as of 0.4.5.

Thanks for the report!

Regards,

Dan



		
__________________________________ 
Do you Yahoo!? 
Take Yahoo! Mail with you! Get it on your mobile phone. 
http://mobile.yahoo.com/maildemo 


More information about the win32utils-devel mailing list