[Win32utils-devel] Some updates and questions on Takaaki's problems

Daniel Berger djberg96 at yahoo.com
Tue Feb 1 21:19:19 EST 2005

Hi all,

I think I've narrowed down the problem with
win32-file.  It appears that EncryptFile() and
DecryptFile are only supported on Win2k or later.  So,
I made some minor modifications to the extconf.rb and
source files and released win32-file 0.4.2 tonight. 
That *should* solve that problem.

As for win32-shortcut, I'm not sure why it doesn't
like IID_IPersistFile, or if that's even the problem. 
Is it possible this only works on Win2k and later?

Regarding win32-taskscheduler, I'm not sure what to
make of it.  The MSDN docs say for NewWorkItem(),
"Requires Windows XP, Windows 2000 Professional,
Windows Me, or Windows 98." for the Client.  So, did
they skip NT 4?

Any insight is welcome.


Do you Yahoo!? 
The all-new My Yahoo! - What will yours do?

More information about the win32utils-devel mailing list