[Win32utils-devel] Re: [ANN] RubyGems 0.2.0

win32utils-devel at rubyforge.org win32utils-devel at rubyforge.org
Mon Mar 15 07:52:45 EST 2004


> I forgot to ask one thing!  Shall we put your gems up on 
> http://gems.rubyforge.org?  We haven't yet figured out how we want to 
> support binary gems when they can work across platforms, but for 
> windows-only gems like these, there's no reason we can't make them 
> available.

Why not ? Let me know what I should do next.

Allow me to finish up my testing and get an OK from the other team
members before we open it up for the world. 

What do you say, Dan? Park?

Meanwhile a few more questions. I haven't quite understood the purpose
of the following lines in gemspec:

 ## What other platform can it be?
 s.platform = Gem::Platform::RUBY  

 ## What do these lines do and how to mention multiple requirements?
 s.requirements << 'drb'                      
 s.require_path = 'lib'                        
 s.autorequire = 'legoR'

And it seems I cannot get uninstall to work:

C:\legoR>gem -i legoR-0.0.1.gem
Successfully installed legoR version 0.0.1

C:\legoR>gem -u legoR-0.0.1.gem
Unknown RubyGem: legoR-0.0.1.gem-> 0.0.0

C:\legoR>tree c:\ruby\lib\ruby\gems
Folder PATH listing
Volume serial number is 71FAE346 6B0E:6992
    ?   ????lib
    ?       ????legoR
    ?   ????lib


More information about the win32utils-devel mailing list