[Win32utils-devel] Re: [ANN] RubyGems 0.2.0

win32utils-devel at rubyforge.org win32utils-devel at rubyforge.org
Sun Mar 14 22:34:15 EST 2004

Hello Chad,

I installed and tried out rubygems for one of the win32-utils
projects named win32-mmap. This is on Win XP (Home).

Here is how I did  it but got some errors (see at the end).
I must be doing something wrong.

Please help ...
-- Shashank

require 'rubygems'

spec = Gem::Specification.new do |s|
 s.add_dependency('ruby', '= 1.8.1')
 s.name = 'win32-mmap'
 s.version = "0.0.2"
 s.platform = Gem::Platform::RUBY
 s.summary = "win32-mmap is a pure-Ruby library for handling memory mapped
files on MS Windows"
 s.requirements << 'Win32 Compiler'
 s.files = Dir.glob("lib/**/*").delete_if {|item| item.include?("CVS")}
 s.require_path = 'win32'     # also tried 'lib/win32'
 s.autorequire = 'win32-mmap'
 s.author = "Dan Berger;Park Heesob"
 s.email = "win32utils-devel at rubyforge.org"
 s.rubyforge_project = "win32-mmap"
 s.homepage = "http://win32utils.rubyforge.org"

if $0==__FILE__

The directory tree looks like this:

Folder PATH listing
Volume serial number is 71FAE346 6B0E:6992
|   +---win32
|       +----- mmap.so


C:\win32utils\win32-mmap>ruby win32-mmap.gemspec
  Successfully built RubyGem
  Name: win32-mmap
  Version: 0.0.2
  File: win32-mmap-0.0.2.gem

C:\win32utils\win32-mmap>gem -i win32-mmap-0.0.2.gem
c:/ruby/lib/ruby/site_ruby/1.8/rubygems.rb:25:in `require_gem':  (LoadError)
Could not find RubyGem ruby
 from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/installer.rb:38:in `install'
 from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/installer.rb:37:in `each'
 from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/installer.rb:37:in `install'
 from c:/ruby/bin/gem:59


More information about the win32utils-devel mailing list