[Win32utils-devel] win32-etc-0.2.2 testing wanted

win32utils-devel at rubyforge.org win32utils-devel at rubyforge.org
Fri Mar 12 08:41:35 EST 2004


> -----Original Message-----
> From: win32utils-devel-bounces at rubyforge.org 
> [mailto:win32utils-devel-bounces at rubyforge.org] On Behalf Of 
> win32utils-devel at rubyforge.org
> Sent: Thursday, March 11, 2004 9:54 PM
> To: win32utils-devel at rubyforge.org
> Subject: Re: [Win32utils-devel] win32-etc-0.2.2 testing wanted
> 
> 
> 
> Hi Dan,
> 
> > No, that's just a typo.  Here's what happens if I just try this:
> 
> Yes, indeed ! Sorry for the noise ...
> 
> > C:\eclipse\workspace\win32-etc-0.2.2\test>ruby test_admin.rb -k foo
> > VERSION: 0.2.2
> > test_admin.rb:48:in `configure_user': unknown error: 87
> > (Win32::Etc::AdminError)
> >
> > 87 is "bad parameter".  I didn't actually track down 
> *which* parameter
> (uh,
> > still trying to figure that out) but knowing that won't 
> make me less 
> > confused (will it?).
> 
> I get a different error number 2221 which means:
>       2221 The user name could not be found. NERR_UserNotFound
> 
> 
> C:\win32utils\win32-etc\test>ruby test_admin.rb -k foo
> VERSION: 0.2.2
> test_admin.rb:48:in `configure_user': unknown error: 2221
> (Win32::Etc::AdminError)
>         from test_admin.rb:48
> 
> C:\win32utils\win32-etc\test>

Hmm...I wondered if somehow it wasn't finding the user.  The only thing
I could think of was that maybe it was a wide-character issue again
(I've seen that happen before).  That, or it's not looking for local
users, only global, but the docs don't say that.

Ideas anyone?

Dan



More information about the win32utils-devel mailing list