[Win32utils-devel] Daemon method name changes

win32utils-devel at rubyforge.org win32utils-devel at rubyforge.org
Fri Feb 6 15:47:25 EST 2004


At the risk of annoying you all to death with seemingly trivial things,
I was thinking that we should change a couple method names.  I know that
I myself had suggested "on_stop", "on_pause", etc, for the event hooks
in the Daemon class.  However, I think I will change those to
"service_stop", "service_pause", etc.  This isn't a major issue, since
we haven't released the code for that yet.

Along those lines, however, I think we should change "worker" to
"service_main".  It's a little more explicit and a little more in line
with the name of the package (i.e. win32-service).  I don't normally
like to switch something like this, but that's one of the reasons I
declared the Daemon code "Alpha" - in case I changed my mind about the

In any case, because of the API change and the new functionality, I'll
release the new code as 0.4.0, unless there's serious objection.

I hope I haven't put anyone to sleep here. ;)



More information about the win32utils-devel mailing list