<p>Had ruby 1.8.7 installed along with 1.9.1. Un-installed both and installed 1.9.2 and the error has gone away. </p>
<div class="gmail_quote">On Oct 31, 2010 11:40 AM, &quot;Tim Pope&quot; &lt;<a href="mailto:vim-ruby-devel@tpope.info">vim-ruby-devel@tpope.info</a>&gt; wrote:<br type="attribution">&gt; Probably a Ruby 1.9 thing. What does `:ruby p RUBY_VERSION` output?<br>
&gt; <br>&gt; I know there&#39;s issues with the omnicomplete plugin. This is the first I&#39;ve<br>&gt; heard of with just the ftplugin.<br>&gt; <br>&gt; On Sat, Oct 30, 2010 at 10:19 PM, Steve Horn &lt;steve@stevehorn.cc&gt; wrote:<br>
&gt; <br>&gt;&gt; When I try to edit an existing or create a new ruby file with gvim on<br>&gt;&gt; Windows I get the following error:<br>&gt;&gt; ----<br>&gt;&gt; Error detected while processing C:\Program Files<br>&gt;&gt; (x86)\Vim\vim73\ftplugin\ruby.vim<br>
&gt;&gt; line 76:<br>&gt;&gt; NoMethodError: undefined method &#39;synchronize&#39; for #&lt;Mutex:0x4019cc0&gt;<br>&gt;&gt; line 93:<br>&gt;&gt; E121: Undefined variable: s:ruby_path<br>&gt;&gt; E15: Invalid expression: s:ruby_path<br>
&gt;&gt;<br>&gt;&gt; Any idea what I might be doing wrong?<br>&gt;&gt;<br>&gt;&gt;<br>&gt;&gt; _______________________________________________<br>&gt;&gt; vim-ruby-devel mailing list<br>&gt;&gt; <a href="mailto:vim-ruby-devel@rubyforge.org">vim-ruby-devel@rubyforge.org</a><br>
&gt;&gt; <a href="http://rubyforge.org/mailman/listinfo/vim-ruby-devel">http://rubyforge.org/mailman/listinfo/vim-ruby-devel</a><br>&gt;&gt;<br></div>