I can't indent html at all.

Ryan Shillington ryanshillington at gmail.com
Thu May 10 11:11:05 EDT 2007


Hi Doug,

Yup, the ruby is indented just fine.  The result of ":let b:eruby_subtype"
is "b:eruby_subtype       html".

Thanks for the quick reply - I appreciate it.

Ryan

On 5/9/07, Doug Kearns <dougkearns at gmail.com> wrote:
>
> G'day Ryan,
>
> On 5/10/07, Ryan Shillington <ryanshillington at gmail.com> wrote:
> > Hey guys,
> >
> > I had previously installed all kinds of rails plugins (probably a
> mismash of
> > things contributed to this project in their earlier days), so I
> uninstalled
> > Vim altogether, did a clean re-install of Vim 7.0 on Windows and
> installed
> > this vim-ruby stuff (version 2007.05.07) using the gem.
> >
> > Now, whenever I select code that looks like the following:
>
> <snip>
>
> > Ah!!! It's destroyed my html formating.  The filename is called
> show.rhtml
> > and I checked that the filetype is being recognized as eruby.  My _vimrc
> is
> > available here (
> > http://www.thebookhauler.com/vimRuby/_vimrc) although I
> > tried it without my _vimrc and got the same results.
> >
> > Any ideas what I might be doing wrong?  That used to work.
>
> FWIW, this works for me on a Windows box....
>
> Your results seem to me to be consistent with the HTML indent file not
> being sourced.  What does :let b:eruby_subtype return?  Is the Ruby
> indented?
>
> <%
>   if true
>     puts "indenting works here"
>   end
> %>
>
> Thanks,
> Doug
> _______________________________________________
> vim-ruby-devel mailing list
> vim-ruby-devel at rubyforge.org
> http://rubyforge.org/mailman/listinfo/vim-ruby-devel
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/vim-ruby-devel/attachments/20070510/a8e8dcc6/attachment.html 


More information about the vim-ruby-devel mailing list