Error detected while processing function <SNR>5_LoadFTPlugin:

Tim Pope vim-ruby-devel at tpope.info
Sun Feb 25 22:12:44 EST 2007


On Sun, Feb 25, 2007 at 09:12:28PM -0400, Aníbal Rojas wrote:
> Hello,
> 
>     I am quite new to vim. Just installed ruby-vim using ruby gems,
> and the install script as indicated. And now, whenever I open a .rb
> file I get the following error:
> 
> Error detected while processing function <SNR>5_LoadFTPlugin:
> line 3:
> E518: Unknow option ofu<
> 
>     After hitting ENTER I can edit the file.
> 
>     This error is displayed both in vim and gvim, version
> 1:6.4-006+2ubuntu. At the bottom of the mail is the output of $ gem
> specification vim-ruby
> 
>     I am not sure if this is the correct place to write this message,
> please let me know if you would prefer this information being posted
> as a bug.

The problem relates to Vim trying to set up omnicompletion, a Vim 7
feature.  The version of ftplugin/ruby.vim in CVS already has this
fixed.

Speaking of which, Doug, any chance of finally doing that release in
the next couple of release?  The ERB indent file still hasn't seen the
light of day yet. :)

Cheers,
Tim


More information about the vim-ruby-devel mailing list