Error detected while processing function <SNR>5_LoadFTPlugin:

Aníbal Rojas anibalrojas at gmail.com
Sun Feb 25 20:12:28 EST 2007


Hello,

    I am quite new to vim. Just installed ruby-vim using ruby gems,
and the install script as indicated. And now, whenever I open a .rb
file I get the following error:

Error detected while processing function <SNR>5_LoadFTPlugin:
line 3:
E518: Unknow option ofu<

    After hitting ENTER I can edit the file.

    This error is displayed both in vim and gvim, version
1:6.4-006+2ubuntu. At the bottom of the mail is the output of $ gem
specification vim-ruby

    I am not sure if this is the correct place to write this message,
please let me know if you would prefer this information being posted
as a bug.

    Thanks id advance,

--
Aníbal Rojas
http://www.rubycorner.com
http://www.hasmanydevelopers.com

$ gem specification vim-ruby
--- !ruby/object:Gem::Specification
rubygems_version: 0.9.1
specification_version: 1
name: vim-ruby
version: !ruby/object:Gem::Version
  version: 2006.07.11
date: 2006-07-10 00:00:00 -04:00
summary: Ruby configuration files for Vim.  Run 'vim-ruby-install.rb'
to complete installation.
require_paths:
- .
email: gsinclair at soyabean.com.au
homepage: http://vim-ruby.rubyforge.org
rubyforge_project: vim-ruby
description: Ruby configuration files for Vim.  Run
'vim-ruby-install.rb' to complete installation.  This package doesn't
contain a Ruby library.
autorequire:
default_executable: vim-ruby-install.rb
bindir: bin
has_rdoc: false
required_ruby_version: !ruby/object:Gem::Version::Requirement
  requirements:
  - - ">="
    - !ruby/object:Gem::Version
      version: 1.8.0
  version:
platform: ruby
signing_key:
cert_chain:
post_install_message:
authors:
- Gavin Sinclair et al.
files:
- ChangeLog
- CONTRIBUTORS
- FAQ
- INSTALL
- NEWS
- README
- bin/vim-ruby-install.rb
- doc/ft-ruby-syntax.txt
- doc/ft-ruby-omni.txt
- autoload/rubycomplete.vim
- compiler/ruby.vim
- compiler/eruby.vim
- compiler/rubyunit.vim
- ftdetect/ruby.vim
- ftplugin/eruby.vim
- ftplugin/ruby.vim
- indent/eruby.vim
- indent/ruby.vim
- syntax/eruby.vim
- syntax/ruby.vim
test_files: []

rdoc_options: []

extra_rdoc_files: []

executables:
- vim-ruby-install.rb
extensions: []

requirements:
- RubyGems 0.8+
- Vim 6.0+
dependencies: []


More information about the vim-ruby-devel mailing list