RSpec and GEMS DSL Keyword Additions to ruby.vim?

Gavin Sinclair gsinclair at gmail.com
Wed Jan 10 20:54:04 EST 2007


On 1/11/07, Rob Muhlestein <rob at muhlestein.net> wrote:
>
> RSpec DSL:
>
>   context
>   context_setup
>   setup
>   specify
>   context_teardown
>   teardown

Sounds good.

> GEMS DSL:
>   require_gem
>   (more I'll look up if worth it)

"require_gem" is deprecated in favour of "gem".  Maybe "require_gem"
should be coloured something ugly to alert people.

Gavin


More information about the vim-ruby-devel mailing list