[long] Still: Bug?: Vim folding for Ruby broken

Hugh Sasse Staff Elec Eng hgs at dmu.ac.uk
Thu Nov 18 14:05:01 EST 2004


On Thu, 18 Nov 2004, Kaspar Schiess wrote:

> Hello Hugh,
>
> a quick update: upon downgrading to vim 62, the problem went away. It is
> a recent one... and one that is specific to windows, apparently.
>
> Here's a %!xxd from my famous test:
> 0000000: 636c 6173 7320 5465 7374 0a20 2064 6566  class Test.  def
         [...]
> 0000070: 640a 656e 640a 0a                        d.end..
>
> As you can see I have switched to using ff=unix, but haven't chased the
> bug with that either.

But it is working for you now is it?  We now have 8 cases I think:
vim6.2.x vs vim6.3.x
running on Windows vs Unix
Using Windows vs Unix file formats

Given that ruby is pretty flexible about file formats something
should work, but it would be nice to fix this as it probably upsets
something else.
>
> So if you want to stop spending time on this bug, I can live with the

I can't spend much time on it, but would be glad to see bugs
removed.

> workaround of vim62. However I am willing to assist with filing bug
> report or further analysis if you are interested.
>
> I have also been contacted by Doug Kearns; I will be redirecting him to
> our discussion this list.

He was certainly on this list before, and he is much more familiar
with the internals of the syntax file than I have ever been.
>
> best regards,
> kaspar
>
         Hugh


More information about the vim-ruby-devel mailing list