[long] Still: Bug?: Vim folding for Ruby broken

Kaspar Schiess eule at space.ch
Thu Nov 18 04:47:17 EST 2004


Hello Hugh,

It really pains me to misthread messages like that, but as the gmane 
announce shows, this should be the last one to get misthreaded. I excuse 
for this.

> OK, I see what your problem is now -- the fold would start at puts
> instead of starting at the line with do, although it doesn't do this
> in a class.  Although I added folding in the first place to ruby's
> vim syntax file, I just added it where it looked right, and was
> unawere of subtleties.  I'm fairly sure others have modified it
> since, but I'm not sure how to track this down...

I have tried several versions of the ruby.vim file; I have tried on 
several machines. A pattern I see here is the following: Versions that 
work on unix machines don't do it on windows versions of VIM. Could this 
somehow (insert explanation here) be a platform issue ?

I have used vim62 and vim63, but on windows machines. As one does on 
windows, I have installed vim trough the self-installing executable that 
can be found on www.vim.org.

> No, mine folds within the methods in the same way in and outside the
> class [file attached for repeatability]  -- this 'cut and paste'ed
> from a vim window:

As I was trying to express in my first mail, its not that much about 
nesting of classes, but about nesting of fold-generating constructs in 
general. Three and below, works, above, does not.

Wait, one idea here, let me see... I had the set fdl=1 setting suspected 
of triggering a vim bug (explaining the different behaviour connected to 
nest depth), but no. I just disabled the setting, and it did not work. 
Makes me think, perhaps you are interested in some parts of my vimrc:

" Enable folding
set fen			" folding enabled
set fdl=1		" fold at level > 2
set fdc=5		" fold column width
set fdm=syntax		" fold method: syntax

> And I don't understand why yours is showing + instead of - for open folds.

That is my manual simulation of vim behaviour...

> :-) as opposed to www.codegeneration.net ? :-)

Indicating what I consider to be the sweet spot on the technology wave...

I am even more at loss with this problem that I was some days ago; I 
can't see why this should be a bug of ruby.vim. I'd probably better to a 
vim mailing list... ?

best regards,
kaspar

hand manufactured code - www.tua.ch/ruby


More information about the vim-ruby-devel mailing list