In typo 4.0.2, neither email or trackbacks work for me.  Well, they don't work using webrick, and they very rarely work using fcgi.  I have tracked it down to a problem in rails and the Dispatch code.  Basically, observers are not restored correctly after Dispatcher::reset_application!  Depending on your setup (lighttpd, webrick, fcgi) and how it uses the dispatcher, you may or may not be affected since the first time your go through the dispatcher, everything works fine, but the subsequent times, the observers are gone, so no email or no trackbacks. 
If you are lucky to get a new ruby instance, it works.<br><br>The way to workaround this is to setup your observers in ApplicationController instead of environment.rb adding this line to the app/controllers/application.rb:
<br><br>&nbsp;observer :content_observer, :email_notifier, :web_notifier
<br><br>I'm still testing the patch before I use it on my site and I'm guessing that's probably an oversight from the rails code, but the workaround seems to work for me.<br><br>Pascal<br><a href="http://blog.nanorails.com" target="_blank" onclick="return top.js.OpenExtLink(window,event,this)">


http://blog.nanorails.com</a><br><br><div><span class="gmail_quote">
On 8/17/06, <b class="gmail_sendername">Trejkaz</b> &lt;<a href="mailto:trejkaz@trypticon.org" target="_blank" onclick="return top.js.OpenExtLink(window,event,this)">trejkaz@trypticon.org</a>&gt; wrote:</span><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">



&gt; Fun :-(.&nbsp;&nbsp;Well, email notifications work for me.&nbsp;&nbsp;If you can find a<br>&gt; fix then I'll roll it up into 4.0.4.<br><br>Okay, I just did a web request and a console request and snipped the state<br>changes out of the logs of both for the purpose of comparison.
<br><br>Here's what happens during a web request:<br><br>#&lt;Comment:0xb6ef4fd0&gt; leaving state ContentState::New<br>#&lt;Comment:0xb6ef4fd0&gt; entering state ContentState::Unclassified<br>#&lt;Comment:0xb6ef61a0&gt; leaving state ContentState::New
<br>#&lt;Comment:0xb6ef61a0&gt; entering state ContentState::Published<br>#&lt;Comment:0xb6ef61a0&gt; leaving state ContentState::Published<br>#&lt;Comment:0xb6ef61a0&gt; entering state ContentState::Unclassified<br>#&lt;Comment:0xb6ef61a0&gt; leaving state ContentState::Unclassified
<br>#&lt;Comment:0xb6ef61a0&gt; entering state Content::JustPresumedHam<br>#&lt;Comment:0xb6ef61a0&gt; leaving state Content::JustPresumedHam<br>#&lt;Comment:0xb6ef61a0&gt; entering state ContentState::PresumedHam<br><br>



And here's a comment sent manually through the console:<br><br>#&lt;Comment:0xb7579d40&gt; leaving state ContentState::New<br>#&lt;Comment:0xb7579d40&gt; entering state ContentState::Unclassified<br>#&lt;Comment:0xb7596a58&gt; leaving state ContentState::New
<br>#&lt;Comment:0xb7596a58&gt; entering state ContentState::Unclassified<br>#&lt;Comment:0xb7596a58&gt; leaving state ContentState::Unclassified<br>#&lt;Comment:0xb7596a58&gt; entering state Content::JustPresumedHam<br>


(NOTIFICATIONS BEING SENT HERE)
<br>#&lt;Comment:0xb7596a58&gt; leaving state Content::JustPresumedHam<br>#&lt;Comment:0xb7596a58&gt; entering state ContentState::PresumedHam<br><br>What's most interesting to me is how the console version never becomes
<br>
&quot;published&quot;, and yet it's the only one where the notifications are sent.<br><br>TX<br><br><br>_______________________________________________<br>Typo-list mailing list<br><a href="mailto:Typo-list@rubyforge.org" target="_blank" onclick="return top.js.OpenExtLink(window,event,this)">



Typo-list@rubyforge.org</a><br><a href="http://rubyforge.org/mailman/listinfo/typo-list" target="_blank" onclick="return top.js.OpenExtLink(window,event,this)">http://rubyforge.org/mailman/listinfo/typo-list</a><br></blockquote>


</div><br>