[typo] db migrate failure in new 6.0.5

Matijs van Zuijlen matijs at matijs.net
Tue Jul 5 04:50:42 EDT 2011


Hi Alan,

Sadly, this is a known bug :-(. I'm working on an overhaul of the 
migrations, many of which were created in prehistory, but I'll try to 
rush a fix for this particular problem today.

In the mean time, you can take a look at

 
http://fdv.lighthouseapp.com/projects/11171/tickets/209-single-table-inheritance-problem

The patch there apparently works (though I have not tested it myself), 
but DO be sure to remove it once the migration is done.

Regards,
Matijs

On 05/07/2011 00:38, Alan Partis wrote:
> I'm setting up a fresh typo 6.0.5 installation.  Downloaded and untarred
> the 6.0.5 tarball.  Ran 'bundle install' and then tried rake db:migrate
> RAILS_ENV=production.  The database existed, but was empty.  I expected
> everything to run smoothly, of course, so I am surprised to be seeing
> this:
>
> ---
>
> Creating shortened URL for existing contents, this may take a moment
> rake aborted!
> An error has occurred, all later migrations canceled:
>
> The single-table inheritance mechanism failed to locate the subclass:
> 'Page'. This error is raised because the column 'type' is reserved for
> storing the class in case of inheritance. Please rename this column if you
> didn't intend it to be used for storing the inheritance class or overwrite
> Content.inheritance_column to use another column for that information.
>
> Tasks: TOP =>  db:migrate
> (See full trace by running task with --trace)
>
> ---
>
>
>
> What am I missing?  I can't imagine there is/was a problem with the
> database as I'm staring with a fresh empty database.  Any thoughts?
>
> Thanks.
>
>
>
> _______________________________________________________
> Alan Partis
> thundernet development group
> _______________________________________________
> Typo-list mailing list
> Typo-list at rubyforge.org
> http://rubyforge.org/mailman/listinfo/typo-list



More information about the Typo-list mailing list