[typo] Fresh ruby 187, rails 3.0.0 and typo 6.0.3 install does not work

Jaymin Shah sjaymin at gmail.com
Tue Feb 8 05:36:24 EST 2011

Thanks for your reply.

I have ensured that there no gem install for bluecloth for any version. I
have also verified that there are no files for bluecloth in cache folder

I had downloaded devkit from http://rubyinstaller.org/downloads and followed
the instruction per
https://github.com/oneclick/rubyinstaller/wiki/Development-Kit. I had also
ensured that devkit is installed properly by following smoke test.

I had then tried installing bluecloth (v2.0.10). It had failed with
following error: (I had also tried removing 2.0.10 version from gem and
cache folder and installing specific version 2.0.5, it got installed without
any error but when I tried to execute db:create or db:migrate - it throws
the error we discussed earlier email). (I had tried on different box as well
ensuring that it has fresh install of Ruby 187 with devkit)

C:\test\typo>gem install bluecloth --platform=ruby

Temporarily enhancing PATH to include DevKit...

Building native extensions.  This could take a while...

ERROR:  Error installing bluecloth:

        ERROR: Failed to build gem native extension.

c:/Ruby187/bin/ruby.exe extconf.rb

checking for srand()... yes

checking for random()... no

checking for rand()... yes

checking for bzero() in string.h,strings.h... no

checking for strcasecmp()... yes

checking for strncasecmp()... yes

checking for mkdio.h... yes

checking for ruby/encoding.h... no

creating extconf.h

creating Makefile


gcc -I. -I. -Ic:/Ruby187/lib/ruby/1.8/i386-mingw32 -I.

f.h\"    -DVERSION=\"2.0.4\" -g -O2 -DFD_SETSIZE=256   -I. -Wall  -c

In file included from




                 from c:/Ruby187/lib/ruby/1.8/i386-mingw32/win32/win32.h:27,

                 from c:/Ruby187/lib/ruby/1.8/i386-mingw32/defines.h:186,

                 from c:/Ruby187/lib/ruby/1.8/i386-mingw32/ruby.h:37,

                 from bluecloth.h:14,

                 from bluecloth.c:25:


9:23: error: duplicate 'unsigned'


8:23: error: duplicate 'unsigned'


8:23: error: two or more data types in declaration specifiers


1:24: error: duplicate 'unsigned'

bluecloth.c: In function 'bluecloth_initialize':

bluecloth.c:190:9: warning: unused variable 'utf8text'

make: *** [bluecloth.o] Error 1

Gem files will remain installed in

.0.10 for inspection.

Results logged to



On Tue, Feb 8, 2011 at 12:00 PM, Matijs van Zuijlen <matijs at matijs.net>wrote:

> On 02/08/2011 02:17 AM, Moshe Suberri wrote:
>> Jaymin Shah wrote in post #979982:
>>> Hi Matijs,
>>> Thanks for your reply. I have tried it and it does not work. Further, I
>>> have Ruby 187 in path and confirmed it too.
>>> Also, I did some search on bluecloth_ext error mentioned below and found
>>> that this is an known issues. I have tried to fix it with suggested fix
>>> but
>>> it did not worked and system continued to give below error.
>>> http://groups.google.com/group/rubyinstaller/browse_thread/thread/59f3812381a195b5
>> I got the same problem. Install Ruby  187 on Windows 7 env.
>> When I run Ruby I get a dialog box with the following error
>> "application aborted error finding ruby...191.dll .."
> Moshe, Jaymin,
> Have you tried uninstalling the bluecloth gem before using the fix
> suggested above? Did you install the Development Kit before using the fix? I
> think it may be needed.
> --
> Matijs
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/typo-list/attachments/20110208/f99c2422/attachment-0001.html>

More information about the Typo-list mailing list