[typo] Fresh ruby 187, rails 3.0.0 and typo 6.0.3 install does not work

Jaymin Shah sjaymin at gmail.com
Sun Feb 6 23:39:08 EST 2011


Matijs van Zuijlen <matijs <at> matijs.net> writes:

> 
> Hi Jaymin,
> 
> It seems rake tries to use ruby 1.9.1 instead of 1.8.7. Can you try 
> running the following:
> 
>    bundle exec rake db:create
> 
> This should force the use of the correct ruby and gems.
> 
> If that doesn't work, can you check where each ruby version is in your path?
> 
> Regards,
> Matijs
> 
> On 02/02/2011 07:49, Jaymin Shah wrote:
> > Hello,
> >
> > I have been trying to install Typo 6.0.3 with fresh box after installing
> > Ruby187 and Rails 3.0.3.
> > Bundle install command runs very smoothly.
> >
> > However, when I try to create database with command “rake db:create”.
> > Application always shows error in window indicating “application failed
> > to start because msvcrt-ruby191.dll was not found. Reinstalling may fix
> > this problem”. (I am using windows). Following log is displayed.
> >
> > C:\typo-6.0.3>rake db:create
> > (in C:/typo-6.0.3)
> > rake aborted!
> > no such file to load -- 1.8/bluecloth_ext
> > c:/ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2383:in
> > `raw_load_rakefile'
> > (See full trace by running task with --trace)
> >
> > It seems that one or more gems being used with application is expecting
> > ruby191 dll file mentioned above.
> >
> > Any help would  be highly appreciated.
> >
> > regards,
> > Jaymin
> 


Hi Matijs,

Thanks for your reply. I have tried it and it does not work. Further, I have
Ruby 187 in path and confirmed it too. 

Also, I did some search on bluecloth_ext error mentioned below and found that
this is an known issues. I have tried to fix it with suggested fix but it did
not worked and system continued to give below error.

ref#
http://groups.google.com/group/rubyinstaller/browse_thread/thread/59f3812381a195b5

regards,
Jaymin



More information about the Typo-list mailing list