[typo] typo 5.1.1 to 5.2 upgrade (now need help with a fastthread issue)

Chris Dagdigian dag at sonsorol.org
Fri Mar 27 03:11:13 EDT 2009


Disregard my fastthrread.so and git/patch incompetence.

I managed to patch the fastthread.c file so that it would not complain  
about the undefined symbol under ruby 1.8.6 and was able to build  
the .so cleanly, pass "rake test" and install it in all the proper  
places.

-chris






On Mar 26, 2009, at 11:39 PM, Chris Dagdigian wrote:

> Hi folks,
>
> I've had sort of an epic journey trying to go from 5.1.1 to 5.2 over  
> the last 2 days ...
>
> In order to even get typo back up I had to (this is the short  
> story ...)
>
> 1. Follow Rick's advice to get datanoise-actionwebservice from  
> gems.github.com
>
> 2. Hand edit the contents of the tags table in the production  
> database to change any tag that had a "." char in it just so I could  
> get past migration #71 (071_fix_tags_naming.rb). The migration that  
> was supposed to do this simply did not work for some reason until I  
> manually made sure there were no tags with "." chars in the  
> database. 50+ edits to SQL table values.
>
> 3. Reorder the migrations because it seemed that migrations prior to  
> 081_create_cache_informations.rb actually depend on the presence of  
> the cache_informations table and bomb out with fatal migration  
> errors when the table is not present. Without the reorder I could  
> not get past migration 078 on the production database
>
> After jumping through all those hoops I seem to have a working  
> install but I'm getting nailed up by a fastthread issue that I'm  
> hoping someone can help me out with.
>
> Using both mongrel and webrick I can reliably crash typo 5.2 with  
> this error:
>
>> ruby: symbol lookup error: /usr/local/lib/ruby/gems/1.8/gems/ 
>> fastthread-1.0.5/lib/fastthread.so: undefined symbol:  
>> rb_thread_alive_p
>
> In this case google is my friend and it seems that there is a git  
> fix for this problem:
>
> http://github.com/mental/fastthread/commits/fastthread-1.0.5
>
> -and-
>
> http://github.com/mental/fastthread/commit/75995d6a097e5b55dc53c39858aea051ce74556e
>
> My main issue is not typo related at this point :) I just don't know  
> enough about git and/or how it is used with gems and ruby to  
> actually implement the patch/fix/hotfix whatever that is referenced  
> in the above URL
>
> Has anyone else run into the "undefined symbol: rb_thread_alive_p" -  
> any tips on rebuilding fastthread-1.0.5 with the fix that resolves  
> the "undefined symbol: rb_thread_alive_p" problem?
>
> Regards,
> Chris
>



More information about the Typo-list mailing list