[typo] typo 5.1.1 to 5.2 upgrade

Chris Dagdigian dag at sonsorol.org
Thu Mar 26 09:47:29 EDT 2009


Hello,

When I follow the upgrade instructions for "gem install typo" I seem  
to get the edge 5.2.98 version which gives me install gripes like this:

...
> Migrating Typo's database to newest release
> config.gem: Unpacked gem coderay-0.8.260 in vendor/gems has no  
> specification file. Run 'rake gems:refresh_specs' to fix this.
> rake aborted!
> no such file to load -- action_web_service
>
> (See full trace by running task with --trace)
> /usr/local/lib/ruby/gems/1.8/gems/typo-5.2.98/bin/typo:59:in  
> `migrate': Migration failed (RailsInstaller::InstallFailed)
> 	from /usr/local/lib/ruby/gems/1.8/gems/rails-app-installer-0.2.0/ 
> lib/rails-installer.rb:689:in `in_directory'
> 	from /usr/local/lib/ruby/gems/1.8/gems/typo-5.2.98/bin/typo:57:in  
> `migrate'
> 	from /usr/local/lib/ruby/gems/1.8/gems/rails-app-installer-0.2.0/ 
> lib/rails-installer.rb:217:in `install_sequence'
> 	from /usr/local/lib/ruby/gems/1.8/gems/rails-app-installer-0.2.0/ 
> lib/rails-installer.rb:192:in `install'
> 	from /usr/local/lib/ruby/gems/1.8/gems/rails-app-installer-0.2.0/ 
> lib/rails-installer/commands.rb:95:in `command'
> 	from /usr/local/lib/ruby/gems/1.8/gems/rails-app-installer-0.2.0/ 
> lib/rails-installer.rb:646:in `execute_command'
> 	from /usr/local/lib/ruby/gems/1.8/gems/typo-5.2.98/bin/typo:93
> 	from /usr/local/bin/typo:19:in `load'
> 	from /usr/local/bin/typo:19
> [dag at dag typo-5.2.98]$
>

Do I have a gem setting or ENV wrong that puts me on the edge track?  
How do I tell gem that I want the stable 5.2? Sorry for the novice  
question.

Regards,
Chris




More information about the Typo-list mailing list