[typo] Having problems upgrading

Rick DeNatale rick.denatale at gmail.com
Tue Mar 24 00:08:00 EDT 2009


I've been running my blog for a long time using typo.  It's been running on
typo 4.1.
My server recently crashed and I decided that it might be a good thing to
upgrade the blog in the process of restoring everything.

I've gotten the old installation directory and a dump of the database onto
my macbook, and it's running under passenger there.

So I've tried to upgrade it to typo 5.2.

The first problem is that when I ran typo install
path/where/typo/isinstalled

It hung endlessly backing up the database.  Now since I already had a mysql
dump, and the install process never seems to use the backup, I bravely
commented out the call to back up in the rails-installer-gem.

Now it gets to the point where it's trying to run the migrations, and it
fails with:

➜ ~ $ sudo typo install typo
 Installing typo 5.2.98
 Stopping Typo
!!! PID file /Users/rick/typo/tmp/pid.txt does not exist.  Not running?
mongrel::stop reported an error. Use mongrel_rails mongrel::stop -h to get
help.
 Checking for existing Typo install in /Users/rick/typo
 Reading files from /opt/local/lib/ruby/gems/1.8/gems/typo-5.2.98
 copying rails 2.2.2 to /Users/rick/typo/vendor/rails/railties
 copying activesupport 2.2.2 to /Users/rick/typo/vendor/rails/activesupport
 copying activerecord 2.2.2 to /Users/rick/typo/vendor/rails/activerecord
 copying actionpack 2.2.2 to /Users/rick/typo/vendor/rails/actionpack
 copying actionmailer 2.2.2 to /Users/rick/typo/vendor/rails/actionmailer
 Making scripts executable
 Checking database
 Database exists, preparing for upgrade
 Migrating Typo's database to newest release
rake aborted!
RubyGem version error: actionpack(1.13.3 not = 1.13.6)

(See full trace by running task with --trace)
/opt/local/lib/ruby/gems/1.8/gems/typo-5.2.98/bin/typo:59:in `migrate':
Migration failed (RailsInstaller::InstallFailed)
from
/opt/local/lib/ruby/gems/1.8/gems/rails-app-installer-0.2.0/lib/rails-installer.rb:689:in
`in_directory'
from /opt/local/lib/ruby/gems/1.8/gems/typo-5.2.98/bin/typo:57:in `migrate'
from
/opt/local/lib/ruby/gems/1.8/gems/rails-app-installer-0.2.0/lib/rails-installer.rb:217:in
`install_sequence'
from
/opt/local/lib/ruby/gems/1.8/gems/rails-app-installer-0.2.0/lib/rails-installer.rb:192:in
`install'
from
/opt/local/lib/ruby/gems/1.8/gems/rails-app-installer-0.2.0/lib/rails-installer/commands.rb:95:in
`command'
from
/opt/local/lib/ruby/gems/1.8/gems/rails-app-installer-0.2.0/lib/rails-installer.rb:646:in
`execute_command'
from /opt/local/lib/ruby/gems/1.8/gems/typo-5.2.98/bin/typo:93
from /opt/local/bin/typo:19:in `load'
from /opt/local/bin/typo:19

The fact that mongrel stop is failing is unsurprising, since it's not
running, and it doesn't seem to hurt.

But I'm at a loss to figure out why rake is failing.  It's not just rake
db:migrate but any use of rake inside the install directory.  It seems to be
associated with that RubyGem version error. But I can't seem to find where
it's calling for 1.13.6.  And 1.13.6 doesn't seem to be available either on
rubyforge or github

$ gem list --both actionpack

*** LOCAL GEMS ***

actionpack (2.3.2, 2.3.1, 2.2.2, 2.1.0, 2.0.2, 1.13.5, 1.13.3)

*** REMOTE GEMS ***

actionpack (2.3.2)

➜ ~ $ gem source
*** CURRENT SOURCES ***

http://gems.rubyforge.org/
http://gems.github.com
➜ ~ $

It would seem that since typo is installing rails 2.2, that a 2.2.x version
of actionpack should be the target anyway.

Any ideas?

-- 
Rick DeNatale

Blog: http://talklikeaduck.denhaven2.com/
Twitter: http://twitter.com/RickDeNatale
WWR: http://www.workingwithrails.com/person/9021-rick-denatale
LinkedIn: http://www.linkedin.com/in/rickdenatale
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/typo-list/attachments/20090324/d1b55d7e/attachment-0001.html>


More information about the Typo-list mailing list