[typo] being stupid with Enterprise Ruby and Typo from github

Cyril Mougel cyril.mougel at gmail.com
Tue Feb 24 08:49:44 EST 2009


Tobias Weisserth wrote:
> Hi Cyril,
>
> thanks for your help. Indeed, I didn't have the 
> datanoise-actionwebservice-2.
> 2.2 gem installed. I got the gem from github's gem repository.
>
> I now have following gems installed:
>
> *** LOCAL GEMS ***
>
> actionmailer (2.2.2)
> actionpack (2.2.2, 1.13.6)
> actionwebservice (1.2.6)
> activerecord (2.2.2, 1.15.6)
> activeresource (2.2.2)
> activesupport (2.2.2, 1.4.4)
> cgi_multipart_eof_fix (2.5.0)
> columnize (0.3.0)
> daemons (1.0.10)
> datanoise-actionwebservice (2.2.2)
> fastthread (1.0.1)
> flexmock (0.8.4)
> gem_plugin (0.2.3)
> htmlentities (4.0.0)
> json (1.1.3)
> linecache (0.43)
> mongrel (1.1.5)
> mongrel_cluster (1.0.5)
> mysql (2.7)
> passenger (2.0.6)
> postgres (0.7.9.2008.01.28)
> rack (0.9.1)
> rails (2.2.2)
> rails-app-installer (0.2.0)
> rake (0.8.3)
> rspec (1.1.12)
> ruby-debug (0.10.3)
> ruby-debug-base (0.10.3)
> ruby-debug-ide (0.4.4)
> sqlite3-ruby (1.2.4)
> typo (5.2)
> will_paginate (2.2.2)
>
> "rake --trace gems" renders:
>
> (in /home/tweisser/workspace/typo/typo)
> rake aborted!
> no such file to load -- 
> /home/tweisser/workspace/typo/typo/config/../vendor/rails/railties/lib/initializer
> /opt/ruby-enterprise-1.8.6-20090201/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in 
> `gem_original_require'
> /opt/ruby-enterprise-1.8.6-20090201/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in 
> `require'
> /home/tweisser/workspace/typo/typo/config/boot.rb:45:in `load_initializer'
> /home/tweisser/workspace/typo/typo/config/boot.rb:38:in `run'
> /home/tweisser/workspace/typo/typo/config/boot.rb:11:in `boot!'
> /home/tweisser/workspace/typo/typo/config/boot.rb:109
> /opt/ruby-enterprise-1.8.6-20090201/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in 
> `gem_original_require'
> /opt/ruby-enterprise-1.8.6-20090201/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in 
> `require'
> /home/tweisser/workspace/typo/typo/Rakefile:4
> /opt/ruby-enterprise-1.8.6-20090201/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:2349:in 
> `load'
> /opt/ruby-enterprise-1.8.6-20090201/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:2349:in 
> `raw_load_rakefile'
> /opt/ruby-enterprise-1.8.6-20090201/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:1985:in 
> `load_rakefile'
> /opt/ruby-enterprise-1.8.6-20090201/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:2036:in 
> `standard_exception_handling'
> /opt/ruby-enterprise-1.8.6-20090201/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:1984:in 
> `load_rakefile'
> /opt/ruby-enterprise-1.8.6-20090201/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:1969:in 
> `run'
> /opt/ruby-enterprise-1.8.6-20090201/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:2036:in 
> `standard_exception_handling'
> /opt/ruby-enterprise-1.8.6-20090201/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:1967:in 
> `run'
> /opt/ruby-enterprise-1.8.6-20090201/lib/ruby/gems/1.8/gems/rake-0.8.3/bin/rake:31
> /opt/ruby-enterprise/bin/rake:19:in `load'
> /opt/ruby-enterprise/bin/rake:19
>
> The same goes for rake db:migrate.
>
> I pulled the latest changes from vanilla typo on github.
>
> I didn't freeze Rails, so vendor/rails is empty.
>
> Do I need to freeze Rails to work on the Typo sources?

We don't need freeze rails gems. I don't understand why you have this 
error. If you made git status, there are no change ?

-- 
Cyril Mougel
http://blog.shingara.fr



More information about the Typo-list mailing list