[typo] can't install typo

Darius darius at onrails.lt
Sun Feb 22 03:50:55 EST 2009


cleanup doesn't help, but thank you, you put me on the right way :) , 
problem is because lastest actionwebservice from gems  depends on 
ationpack 1.13.6, activerecord 1.15.6 and activesupport 1.4.4

i  install actionwebservice from github ant its work :)



Tobias Weisserth wrote:
> Hi there,
>
> I am trying to figure out the exact same problem here.
>
> I tried to run "rake db:migrate" and get similar issues.
>
> I tried to get rid of old versions of gems by "sudo gem cleanup" which 
> solved the problem you are having right now just to run into the next 
> problem. Try this first and please let me know on this list if this 
> resolved it for you.
>
> Thanks,
>
> Tobias
>
> On Sat, Feb 21, 2009 at 10:46 PM, Darius <darius at onrails.lt 
> <mailto:darius at onrails.lt>> wrote:
>
>     Hello,
>
>     I try install typo, on my local machine, after set database
>     config, i try start application and get fallowing error:
>
>     /usr/local/lib/site_ruby/1.8/rubygems.rb:149:in `activate': can't
>     activate actionpack (= 1.13.6, runtime), already activated
>     actionpack-2.2.2 (Gem::Exception)
>           from /usr/local/lib/site_ruby/1.8/rubygems.rb:165:in `activate'
>           from /usr/local/lib/site_ruby/1.8/rubygems.rb:164:in `each'
>           from /usr/local/lib/site_ruby/1.8/rubygems.rb:164:in `activate'
>           from
>     /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:35:in
>     `require'
>           from
>     /var/lib/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies.rb:153:in
>     `require'
>           from
>     /var/lib/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies.rb:521:in
>     `new_constants_in'
>           from
>     /var/lib/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies.rb:153:in
>     `require'
>           from
>     /var/lib/gems/1.8/gems/rails-2.2.2/lib/initializer.rb:256:in
>     `require_frameworks'
>           from
>     /var/lib/gems/1.8/gems/rails-2.2.2/lib/initializer.rb:256:in `each'
>           from
>     /var/lib/gems/1.8/gems/rails-2.2.2/lib/initializer.rb:256:in
>     `require_frameworks'
>           from
>     /var/lib/gems/1.8/gems/rails-2.2.2/lib/initializer.rb:133:in `process'
>           from
>     /var/lib/gems/1.8/gems/rails-2.2.2/lib/initializer.rb:112:in `send'
>           from
>     /var/lib/gems/1.8/gems/rails-2.2.2/lib/initializer.rb:112:in `run'
>           from /home/darius/workspace/github/typo/config/environment.rb:19
>           from
>     /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:in
>     `gem_original_require'
>           from
>     /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:in
>     `require'
>           from
>     /var/lib/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies.rb:153:in
>     `require'
>           from
>     /var/lib/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies.rb:521:in
>     `new_constants_in'
>           from
>     /var/lib/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies.rb:153:in
>     `require'
>           from
>     /var/lib/gems/1.8/gems/rails-2.2.2/lib/commands/servers/webrick.rb:59
>           from
>     /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:in
>     `gem_original_require'
>           from
>     /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:in
>     `require'
>           from
>     /var/lib/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies.rb:153:in
>     `require'
>           from
>     /var/lib/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies.rb:521:in
>     `new_constants_in'
>           from
>     /var/lib/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies.rb:153:in
>     `require'
>           from
>     /var/lib/gems/1.8/gems/rails-2.2.2/lib/commands/server.rb:49
>           from
>     /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:in
>     `gem_original_require'
>           from
>     /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:in
>     `require'
>           from script/server:3
>
>     it seems like problem with actionpack, i have installed fallowing
>     versions actionpack 2.2.2, 2.0.2, 1.13.6
>     maybe someone know how to fix it ?
>     _______________________________________________
>     Typo-list mailing list
>     Typo-list at rubyforge.org <mailto:Typo-list at rubyforge.org>
>     http://rubyforge.org/mailman/listinfo/typo-list
>
>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/typo-list/attachments/20090222/8a57ee2a/attachment.html>


More information about the Typo-list mailing list