[typo] [ANN] Typo 5.2 for Rails 2.2 released

Cyril Mougel cyril.mougel at gmail.com
Tue Feb 17 05:35:42 EST 2009


Jamie Penney wrote:
> I am having an issue upgrading from 5.1.3. I have:
> 1) installed the upgraded typo gem
> 2) run `typo install .` in my typo directory
> 3) cleared the sessions with rake db:sessions:clear
> 4) double checked the migrations have worked with rake db:migrate
>
> The issue I have is this: When I try log in, it tries to navigate to 
> /admin/settings/update_database. This fails, and the logs contain the 
> following:
>
> Processing Admin::SettingsController#update_database (for 121.98.143.175 
> at 2009-02-17 09:04:30) [GET]
>   Session ID: e70ccad1ea97ae3270cfcc699458d192
> Rendering template within layouts/administration
> Rendering admin/settings/update_database
>
>
> ActionView::TemplateError (undefined method `editor' for 
> #<User:0xb67c53c4>) on line #8 of 
> app/views/layouts/administration.html.erb:
> 5:   <meta http-equiv="Content-type" content="text/html; charset=utf-8" 
> />
> 6:   <title>Typo Administration:  <%= controller.controller_name 
> %></title>
> 7:   <meta http-equiv="imagetoolbar" content="no" />
> 8:   <%= javascript_include_tag :fckeditor if current_user.editor == 2 
> %>
> 9:   <%= javascript_include_tag 'quicktags' if current_user.editor == 0 
> %>
> 10:   <%= stylesheet_link_tag "administration", "lightbox" %>
> 11:   <%= stylesheet_link_tag "administration_rtl" if ( 
> _("Localization.rtl") == "1") %>
>
>     vendor/rails/activerecord/lib/active_record/attribute_methods.rb:260:in 
> `method_missing'
>     app/views/layouts/administration.html.erb:8
>
> Any ideas as to how to fix this?
>
>   

The editor field is insert in Typo 5.2

Maybe try a restart of Typo, with delete all cookie and restart rake 
db:migrate.

- Stop Typo
- rake db:sessions:clear
- rake db:migrate
- Start Typo

Maybe you are a old user model in your session or your migration failed.

-- 
Cyril Mougel
http://blog.shingara.fr



More information about the Typo-list mailing list