[typo] Release of Typo 5.0.2

Ryan Lewis ruby-forum-incoming at andreas-s.net
Tue Mar 25 02:02:27 EDT 2008


Ryan Lewis wrote:
> Frederic de Villamil wrote:
>>> database, so you might well have references to things that don't exist
>>> in the release.
>> 
>> I plan to fix this in 5.0.3 or 5.0.4 (or 5.1) with the introduction of
>> a plugin manager that will detect missing plugins and offer to install
>> them. I actually thought that an error message when you log in would
>> have been sufficient.
>> 
>> Best regards,
>> Fr�d�ric
> 
> I am having this same problem, but with Typo 5.0.3, using PostgreSQL on
> top of ./script/server running mongrel in development mode.  Via the
> admin interface, I can very rarely get the Pages plugin to load, but
> never any of the other plugins.  Is there a way to do this without using
> the drag-and-drop method?  The error seen is as follows (same as noted
> previously):
> 
> <pre>
> ActiveRecord::AssociationTypeMismatch (Blog expected, got Blog):
>     /vendor/rails/activerecord/lib/active_record/associations/association_proxy.rb:150:in
> `raise_on_type_mismatch'
>     /usr/local/lib/ruby/gems/1.8/gems/activerecord-2.0.2/lib/active_record/associations/belongs_to_association.rb:22:in
> `replace'
>     /usr/local/lib/ruby/gems/1.8/gems/activerecord-2.0.2/lib/active_record/associations.rb:1009:in
> `blog='
>     /usr/local/lib/ruby/gems/1.8/gems/activerecord-2.0.2/lib/active_record/base.rb:2117:in
> `send'
>     /usr/local/lib/ruby/gems/1.8/gems/activerecord-2.0.2/lib/active_record/base.rb:2117:in
> `attributes='
>     /usr/local/lib/ruby/gems/1.8/gems/activerecord-2.0.2/lib/active_record/base.rb:2116:in
> `each'
>     /usr/local/lib/ruby/gems/1.8/gems/activerecord-2.0.2/lib/active_record/base.rb:2116:in
> `attributes='
>     /usr/local/lib/ruby/gems/1.8/gems/activerecord-2.0.2/lib/active_record/base.rb:1926:in
> `initialize'
>     /app/models/sidebar.rb:195:in `initialize'
> ...
> </pre>
> 
> Is there a real fix for this issue?  Is the problem even with the
> ActiveRecord::base.connection.execute call at all?  I have tried
> clearing the database table and trying to re-add the plugins via the
> admin interface, but it still doesn't work.
> 
> I admit that I am not very well versed with Rails.  I tried to rewrite
> the this_blog.sidebars.update_all('active_position = null') call to do
> separate calls for each sidebar, but it didn't work.  I'm not sure if it
> was an issue with my end of not.
> 
> Any help would be greatly appreciated.  Thanks!
> -RyanL
> 
> 
> --
> Posted via forums.bring.out.ba.

Okay, so it seems like the problem is solved.  I'm not sure what exactly 
fixed it, but it was one of the following:

- Removed Google Analytics plugin and references to Rubaidh plugin 
repository.
- I had both recent comments and recent posts installed as plugins.  The 
title is the same ("Recent") and I could never select recent_posts 
sidebar (the 2nd entry).  Action taken was I removed the recent comments 
plugin.
- Updated app/controllers/admin/sidebar_controller.rb from the 5.0.3 
release to the trunk changes (r1677).

The second point may be a bug, which I'd be happy to write up a ticket 
for if it is.  I am doing my testing in cgi/development mode, so it's 
quite slow, so I'll test that later.


-- 
Posted via http://www.ruby-forum.com/.


More information about the Typo-list mailing list