[typo] Release of Typo 5.0.2

Ryan Lewis mail_gw_ruby at dev-infra-2.sigma-com.net
Sun Mar 23 18:06:48 EDT 2008

Frederic de Villamil wrote:
> Le 7 janv. 08 � 19:21, Rick DeNatale a �crit :
>>> Actually I'm using a fresh installation folder of v5.0.2.. I only
>>> modified the database.yml file to point to my old database and then  
>>> ran
>>> the migration.  So there shouldn't be any legacy themes or plugins
>>> interfering.
>> Except that the configuration of which sidebars/themes etc is IN the
>> database, so you might well have references to things that don't exist
>> in the release.
> I plan to fix this in 5.0.3 or 5.0.4 (or 5.1) with the introduction of
> a plugin manager that will detect missing plugins and offer to install
> them. I actually thought that an error message when you log in would
> have been sufficient.
> Best regards,
> Fr�d�ric

I am having this same problem, but with Typo 5.0.3, using PostgreSQL on
top of ./script/server running mongrel in development mode.  Via the
admin interface, I can very rarely get the Pages plugin to load, but
never any of the other plugins.  Is there a way to do this without using
the drag-and-drop method?  The error seen is as follows (same as noted 

ActiveRecord::AssociationTypeMismatch (Blog expected, got Blog):
    /app/models/sidebar.rb:195:in `initialize'

Is there a real fix for this issue?  Is the problem even with the
ActiveRecord::base.connection.execute call at all?  I have tried
clearing the database table and trying to re-add the plugins via the
admin interface, but it still doesn't work.

I admit that I am not very well versed with Rails.  I tried to rewrite
the this_blog.sidebars.update_all('active_position = null') call to do
separate calls for each sidebar, but it didn't work.  I'm not sure if it
was an issue with my end of not.

Any help would be greatly appreciated.  Thanks!

Posted via forums.bring.out.ba.

More information about the Typo-list mailing list