[typo] db:create gives "Unknown database"

Scott Likens damm at livid.dk
Thu Jun 19 19:39:37 EDT 2008


Hi,

It wasn't that I had any doubt that db:create should work, it was that  
rake task is defined in rails, and not typo.  So I felt it was more  
rails related.  Where it's casued or ended, I don't know.

it works for me with regular ruby 1.8.6, I don't use jruby so I did  
not test, but I assume that jruby is unrelated.

Unfortunately, I am a believer in testing w/ ruby only, as I have  
found some unique problems using rubinus, YARV and jruby that do not  
happen elsewhere...

When in doubt, try it the "normal" way, and if it works, backtrack and  
find out where and why it's failing.

... however for me personally I try to run a secure MySQL Server; so I  
give each rails app it's own login credentials, and db:create will/ 
would fail because I do not give it permission to create a database.   
Which is why I find db:create rake task to be downright silly.

Thanks for listening, no reply necessary.


On Jun 19, 2008, at 6:57 AM, Michael Hasenstein wrote:

> Arun Gupta wrote:
>
>> AIU the main point of db:create is to create the database. Since  
>> Rails
>> 2.0, I've never use mysqladmin command to create the database and
>> always used db:create. I'm still confused why I need to explicitly
>> create the database using mysqladmin.
>> -Arun
>
>
> Hi Arun,
>
> No one here believes you? Well I do... had the same error. I found
> several URLs of the same sort, like
> http://justbarebones.blogspot.com/2008/05/rails-202-restful-authentication-and.html
> and this very recent bug report:
> http://rails.lighthouseapp.com/projects/8994/tickets/63-bug-rake-db-create-and-observers
> However, I ended up giving up on rails and created my database  
> manually.
> It IS a bug in rails, maybe triggered by one of the plugins, who  
> knows.
> Since it only shows up at db creation time I thought it not worth
> investigating further.
>
>
> To all those doubters here, first, db:create IS supposed to create the
> database. When I run it and the (empty!) schema exists it complains
> about this fact. When the schema doesn't exist I get the same error as
> Arun. It's just another bug in rails.
>
> Michael
> -- 
> Posted via http://www.ruby-forum.com/.
> _______________________________________________
> Typo-list mailing list
> Typo-list at rubyforge.org
> http://rubyforge.org/mailman/listinfo/typo-list
>
> !DSPAM:485a6628234381188853893!
>
>



More information about the Typo-list mailing list